Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > SecureCRT on the Mac

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 10-24-2016, 05:53 PM
Blues Blues is offline
Registered User
 
Join Date: Oct 2016
Posts: 4
SecureCRT in Dock losing state across reboots

I am running into a problem with maintaining SecureCRT in the dock across reboots. I can minimize a running SecureCRT session to the dock and can "pin" it there by right clicking on the SecureCRT icon in the dock and choosing "options / Keep In Dock." I then then close SecureCRT and relaunch it from the icon in the dock, but only for a period of time.

This above method should allow me to keep a SecureCRT icon in the dock across multiple sessions of shutting dock my Mac or rebooting. What I am finding, however, is that the SecureCRT icon dock becomes a question mark after rebooting. This generally means that an application has been removed from the operating system. This is definitely not the case as I can always re-launch SecureCRT from the applications folder. The issue seems to be with the dock icon losing its state across reboots.

Has anyone else run into this problem? If so, has anyone found workable solution? My thanks for any feedback.
Reply With Quote
  #2  
Old 10-24-2016, 06:46 PM
jdev's Avatar
jdev jdev is offline
VanDyke Technical Support
 
Join Date: Nov 2003
Location: Albuquerque, NM
Posts: 802
Which specific version of Mac OS X are you on with this machine?

When you "install" SecureCRT, what is the exact path that you are installing it to on your OS X system?

I have a suspicion that if you're on OS X Sierra, you may very well be running into a known side effect of Gatekeeper Path Randomization, which can present itself as the behavior you're seeing, since the actual path to the app changes randomly across os boots if you're not installing SecureCRT to /Applications.

If you're not installing to /Applications, that would be the first thing to do as an attempt to resolve the situation. You would accomplish this by opening the SecureCRT .dmg file, and then drag the SecureCRT app from there and drop it into your /Applications folder.

--Jake
__________________
Jake Devenport
VanDyke Software
Technical Support
support@vandyke.com
http://www.vandyke.com/support
Reply With Quote
  #3  
Old 10-25-2016, 04:07 PM
Blues Blues is offline
Registered User
 
Join Date: Oct 2016
Posts: 4
I am running Sierra. SecureCRT is install in /Applications.
Reply With Quote
  #4  
Old 10-25-2016, 05:17 PM
Blues Blues is offline
Registered User
 
Join Date: Oct 2016
Posts: 4
I just ran a couple of tests and am finding some interesting results. First, I am running Sierra. SecureCRT is installed in /Applications. When I launch SecureCRT from the /Applications folder, I check the docked icon's path by opening "/Library/Preferences/com.apple.dock.plist". (See https://apple.stackexchange.com/ques...h-of-dock-icon for details). While SecureCRT is running I see that the application path is /Applications.

Before closing SecureCRT, I right click on the dock icon and choose " Options / Keep In Dock". From there, I can then close SecureCRT and the dock icon remains present as expected. I then wait a few minutes and try to re-execute SecureCRT from the dock icon, but it fails and I get a question mark icon. Interesting...

Remember that I checked the docked icon's path when SecureCRT was running and it showed /Applications as the app path. Once I get question mark icon I again check the docked icon's app path and I get:

file:///private/var/folders/t6/wsxh8rjj2czc0ysl08z3d7vc0000gp/T/AppTranslocation/016B2327-1A98-401D-BF07-4C82A2BA094D/d/SecureCRT.app/

Very interesting that the dock icon app path changes from a) when SecureCRT is running versus b) then application itself is closed. This may be related to Gatekeeper Path Randomization. If so, I have no idea how to resolve the issue. SecureCRT is the only program where I have seen this problem. Its obviously an OS related issue. Any thoughts on a workaround given I am running SecureCRT from /Applications would be appreciated.
Reply With Quote
  #5  
Old 10-25-2016, 05:39 PM
Blues Blues is offline
Registered User
 
Join Date: Oct 2016
Posts: 4
After some digging, I found what I believe is a manual resolution. The issue seems to be related to the fact that quarantine flag was not removed from the SecureCRT app, despite the fact that I used Finder to copy it from the install DMG to /Applications. The below link is what clued be in on the issue and resolution:

https://github.com/potionfactory/LetsMove/issues/56

The short fix to the problem was to run the following command via a terminal window:
xattr -dr com.apple.quarantine /Applications/SecureCRT.app/
Once I did that I was able to keep my SecureCRT dock icon intact across reboots and have it maintain the proper app path for the dock icon. Thanks.

Last edited by jdev; 10-25-2016 at 06:25 PM. Reason: Make workaround command more visible
Reply With Quote
  #6  
Old 10-25-2016, 06:22 PM
jdev's Avatar
jdev jdev is offline
VanDyke Technical Support
 
Join Date: Nov 2003
Location: Albuquerque, NM
Posts: 802
Blues,

Looks like you nailed it. Gatekeeper Path Randomization (GPR) at work. We're still looking into the right fix, and we'll post here when we find one.

Another solution *might* have been to copy the SecureCRT app from the DMG to your Downloads folder and then move the SecureCRT app from Downloads to your /Applications folder, since GPR appears to be disabled if you manually move a file in Finder from one folder to another.

Like you, it's unclear to me why copying directly from the DMG to /Applications didn't work for you.

I'm glad you found a solution that works well for you, and I express appreciation to you for posting the solution here on the forums. Hopefully others will be able to benefit from the information you've discovered.

--Jake
__________________
Jake Devenport
VanDyke Software
Technical Support
support@vandyke.com
http://www.vandyke.com/support
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 05:59 AM.