Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > General

Reply
 
Thread Tools Display Modes
  #1  
Old 01-04-2020, 12:37 PM
gmgtxus gmgtxus is offline
Registered User
 
Join Date: Jan 2020
Posts: 4
SecureCRT logging

I have the logging parameter. I want the session name appeared as the device name (Ex. Router1, Router2) but in this case, it always says "Default".

C:\Users\%USERNAME%\Documents\SecureCRTLogs\%Y-%M-%D\%S %H %h%m %s.txt


Output:

C:\Users\%USERNAME%\Documents\SecureCRTLogs\2020-01-04\
Default 10.101.0.10 1329 06
Default 10.101.0.10 1327 53

Appreciated any help.

Thanks
Reply With Quote
  #2  
Old 01-04-2020, 01:07 PM
berdmann berdmann is offline
VanDyke Technical Support
 
Join Date: Aug 2017
Posts: 319
Hi gmgtxus,

The behavior that you are experiencing generally occurs when a session name was not provided for the session.

If you right-click on the desired session in the Session Manager, select "Properties" and navigate to the "Connection" category, is there a name specified that differs from the hostname?



If not, please enter the desired name and re-test. What are your results?
Attached Images
File Type: png SecureCRT_SessionName.png (33.9 KB, 126 views)
__________________
Thanks,
--Brittney

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #3  
Old 01-04-2020, 01:26 PM
gmgtxus gmgtxus is offline
Registered User
 
Join Date: Jan 2020
Posts: 4
Hi Berdmann,

The connection name is Default.

I'm wondering coz this is when i clicked devices from a GUI (Ex. EVE-NG).

Basically, this is not a static session defined in a session manager.
Reply With Quote
  #4  
Old 01-04-2020, 01:58 PM
gmgtxus gmgtxus is offline
Registered User
 
Join Date: Jan 2020
Posts: 4
Hi,

I think, I see the difference. Yes, if it's statically assigned in Session Manager, it logged with the session name.

In my case, I clicked routers through a GUI (EVE-NG). So, it seems appear as "default". Any thoughts for any possible fix?

Thanks
Reply With Quote
  #5  
Old 01-06-2020, 10:49 AM
berdmann berdmann is offline
VanDyke Technical Support
 
Join Date: Aug 2017
Posts: 319
Hi gmgtxus,

When you launch SecureCRT using EVE-NG, SecureCRT creates a single-use (ad-hoc) session using the Default Session's settings.

Since the Default Session's settings are used, SecureCRT is unable to capture the EVE-NG device name that you see in SecureCRT once you connect.

I have captured a feature request on your behalf to add a "tab name" logging substitution variable that, if implemented, would provide you with the desired functionality.

We will be sure to post here if a version of SecureCRT that supports this method is released. If you would prefer direct notification, please send an email to support@vandyke.com, with ***ATTN: Feature Request, Forum Thread #14028*** in the subject field.
__________________
Thanks,
--Brittney

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #6  
Old 01-06-2020, 06:05 PM
gmgtxus gmgtxus is offline
Registered User
 
Join Date: Jan 2020
Posts: 4
Hi Brittney,

Oh that's very good news. I'm sure it will be benefit to a lot of users. Appreciated for the positive feedback and looking forward to it.

Thanks-
Gerard
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 01:41 PM.