Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > General

Notices

Reply
 
Thread Tools Display Modes
  #1  
Old 04-04-2021, 03:11 PM
sudo sudo is offline
Registered User
 
Join Date: May 2017
Posts: 9
Can't start SCRT anymore (Linux)

I installed as OS ParrotOS which is based on debian and installed securecrt which is my favorite SSH tool.
In the past it was no problem to start securecrt. but i did an OS upgrade and since then i am not able to start scrt. Then i tried to upgrade from securecrt from 8.5 to 9.0 but i get the same messages. i am not able to start this program anymore.
If i want to start via the menu the scrt-icon will be shown in the taskbar but it doesn't start and the icon does disappear after a certain time. If i want to start securecrt via console i will get the message "SecureCRT: error while loading shared libraries: libicui18n.so.66: cannot open shared object file: No such file or directory"
I don't find any logs about the problem in /var/logs and didn't find any logs about securecrt everywhere else. The tipps to reinstall libpythos, libssl, libjpeg i have done. Also i purged and removed securecrt and reinstalled but problem is still there.
do you another tipps or can help please?


tree

Code:
tree /usr/lib/scrt /usr/lib/scrt ├── lib │   ├── libQt5DBus.so.5 │   └── libQt5XcbQpa.so.5 ├── libClientConfigUiQt.so ├── libCommonUiQt.so ├── libpython3Qt.so ├── libQt5Core.so.5 ├── libQt5Gui.so.5 ├── libQt5Multimedia.so.5 ├── libQt5Network.so.5 ├── libQt5PrintSupport.so.5 ├── libQt5Widgets.so.5 └── plugins     ├── platforminputcontexts     │   ├── libcomposeplatforminputcontextplugin.so     │   └── libibusplatforminputcontextplugin.so     └── platforms         └── libqxcb.so


Logs:

2021-04-03 20:54:30 remove scrt:amd64 9.0.0-2430 <none>
 2021-04-03 20:54:30 status half-configured scrt:amd64 9.0.0-2430
2021-04-03 20:54:30 status half-installed scrt:amd64 9.0.0-2430
2021-04-03 20:54:30 status config-files scrt:amd64 9.0.0-2430
2021-04-03 20:54:30 status not-installed scrt:amd64 <none>
2021-04-03 20:55:45 install scrt:amd64 <none> 9.0.0-2430
2021-04-03 20:55:45 status half-installed scrt:amd64 9.0.0-2430
2021-04-03 20:55:47 status unpacked scrt:amd64 9.0.0-2430
2021-04-03 20:55:47 configure scrt:amd64 9.0.0-2430 9.0.0-2430
2021-04-03 20:55:47 status half-configured scrt:amd64 9.0.0-2430
2021-04-03 20:55:47 status installed scrt:amd64 9.0.0-2430
2021-04-03 21:38:34 upgrade scrt:amd64 9.0.0-2430 9.0.0-2430
2021-04-03 21:38:34 status half-configured scrt:amd64 9.0.0-2430
2021-04-03 21:38:34 status unpacked scrt:amd64 9.0.0-2430
2021-04-03 21:38:34 status half-installed scrt:amd64 9.0.0-2430
2021-04-03 21:38:35 status unpacked scrt:amd64 9.0.0-2430
2021-04-03 21:38:35 configure scrt:amd64 9.0.0-2430 9.0.0-2430
2021-04-03 21:38:35 status half-configured scrt:amd64 9.0.0-2430
2021-04-03 21:38:35 status installed scrt:amd64 9.0.0-2430

┌─[xyz@parrot]─[/var/log]
└──╼ $sudo grep -rI --exclude="dpkg.log" "scrt" *
apt/history.log:Commandline: /usr/bin/apt remove -f scrt
apt/history.log:Remove: scrt:amd64 (9.0.0-2430)
apt/history.log:Commandline: /usr/bin/apt --purge remove scrt
apt/history.log:Purge: scrt:amd64 (9.0.0-2430)
apt/history.log:Commandline: /usr/bin/apt --purge remove scrt
apt/history.log:Purge: scrt:amd64 (9.0.0-2430)
apt/term.log:Entfernen von scrt (9.0.0-2430) ...
apt/term.log:Entfernen von scrt (9.0.0-2430) ...
apt/term.log:Entfernen von scrt (9.0.0-2430) ...

 ┌─[xyz@parrot]─[/var/log] └──╼ $sudo grep -rI --exclude="dpkg.log" "scrt" * apt/history.log:Commandline: /usr/bin/apt remove -f scrt apt/history.log:Remove: scrt:amd64 (9.0.0-2430) apt/history.log:Commandline: /usr/bin/apt --purge remove scrt apt/history.log:Purge: scrt:amd64 (9.0.0-2430) apt/history.log:Commandline: /usr/bin/apt --purge remove scrt apt/history.log:Purge: scrt:amd64 (9.0.0-2430) apt/term.log:Entfernen von scrt (9.0.0-2430) ... apt/term.log:Entfernen von scrt (9.0.0-2430) ... apt/term.log:Entfernen von scrt (9.0.0-2430) ...  ┌─[yz@parrot]─[/var/log] └──╼ $sudo grep -rI --exclude="dpkg.log" "securecrt" * ┌─[✗]─[xyz@parrot]─[/var/log]
many thanks
Reply With Quote
  #2  
Old 04-05-2021, 08:54 AM
cboyack cboyack is offline
VanDyke Technical Support
 
Join Date: Apr 2020
Location: Albuquerque, NM
Posts: 132
Hi sudo,

Unfortunately, since Parrot OS is not an officially supported platform for SecureCRT, there's not any further official advice that we can share with you regarding how to get SecureCRT working on the newer Parrot OS. From the error message that you're seeing, it looks like SecureCRT requires the use of libicu66, which is not part of that OS's distro.

You may be able to get the software working by downloading and installing libicu66 through whatever means are available to you on that OS, but again, as SecureCRT is not supported on that particular OS, such experimentation is in your court.

I've added your information to the current feature request to officially support Parrot OS as a platform for SecureCRT.

If you prefer direct email notification should such a change be made, please send an email to support@vandyke.com and include Feature Request - Forum Thread #14487 in the subject line or use this form from the support page of our website.
__________________
Thanks,
--Cameron

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 05:24 AM.