VanDyke Software Forums

Go Back   VanDyke Software Forums > SecureCRT 5.0 Alpha/SecureFX 3.0 Alpha
User Name
Password
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
 
Thread Tools Rate Thread Display Modes
  #1  
Old 02-16-2005, 05:36 AM
mwb mwb is offline
Registered User
 
Join Date: Dec 2004
Posts: 3
Session Wizard default port incorrect for SSH2 (build 711)

When creating a new session with the new Session Wizard for SSH2, the port defaults to 23, not 22. Selecting SSH1 correctly sets it to 22.

Also, if you select "None" for the protocol, then select SFTP, the port again is incorrectly set to 23.

-Matt

Last edited by mwb; 02-16-2005 at 05:44 AM.
  #2  
Old 02-16-2005, 05:31 PM
Maureen's Avatar
Maureen Maureen is offline
VanDyke Product Director
 
Join Date: Feb 2004
Location: Albuquerque, NM
Posts: 1,612
For a while, there was a bug where SSH2 was defaulting to port 23 and it's possible that your default session got saved this way. SSH2 and SFTP share configuration information, which is why you're seeing the same behavior for SFTP.

There are a couple of ways to fix this. If you haven't made changes to your default session, you could go into your config folder and delete the Default.ini file. If you have made changes to your default session that you'd like to save, you could edit your defaut session through the Global Configuration dialog and change the default port for SSH2 to 23. If neither of these fixes the problem, please let me know.

Maureen
  #3  
Old 02-17-2005, 07:16 PM
mwb mwb is offline
Registered User
 
Join Date: Dec 2004
Posts: 3
Thanks... That appears to have corrected that problem. However, while correcting that issue, I found another.

If you go into Default Session/Edit Default Settings… , Click on File Transfer, then FTP/SFTP, in the grayed out “File Creation Mask” is three characters. Selecting any other button results in a popup saying “Invalid Octal Digit.” The only way to get out is to cancel.

This exists in build 722.


-Matt

Last edited by mwb; 02-17-2005 at 07:26 PM.
  #4  
Old 02-18-2005, 12:23 PM
Maureen's Avatar
Maureen Maureen is offline
VanDyke Product Director
 
Join Date: Feb 2004
Location: Albuquerque, NM
Posts: 1,612
Thanks for posting this report. I saw the same thing you described. Once I exited SecureCRT and restarted, I didn't see it again. Are you able to get it to happen consistently?

Maureen
  #5  
Old 02-19-2005, 03:01 PM
mwb mwb is offline
Registered User
 
Join Date: Dec 2004
Posts: 3
Yes... I can reproduce it every time. It only appears after selecting "File Transfer"

Matt
 

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 10:38 PM.


© copyright 1995-2017 VanDyke Software, Inc.