Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > Secure Shell

Reply
 
Thread Tools Display Modes
  #1  
Old 04-26-2010, 09:33 PM
SteveB-in-LV's Avatar
SteveB-in-LV SteveB-in-LV is offline
Registered User
 
Join Date: Sep 2009
Posts: 7
Cut-and-paste Buffer seems to be truncated or garbled after about 3300 characters

Greetings all.

...here's hoping this is an easy question to answer for someone out there.

During a CLI session with a Cisco device (Serial, telnet or SSH – it doesn’t seem to matter), when I try to send a series of CLI commands using cut-and-paste, the full contents of the Cut-and-Paste Buffer seem to get garbled, out-of-sync with the IOS CLI or otherwise don't make it all the way to the target device.

Somewhere after about the first 3300 characters, the target CLI starts complaining about unrecognized commands and bad syntax. The last command in the buffer DOES make it to the CLI but a comparison of the sent commands and the resulting configuration on the target device, show that several commands in the middle of the sent buffer did not make it.

I suspect this is some kind of a buffer limitation or a timing issue between the sending device and the Cisco CLI.

Has anyone seen this problem before and know of a fix for it?
For instance, is there some kind of delay or flow-control setting that might need to be adjusted or is there a way to increase the size of the cut-and-paste buffer recognized by SecureCRT?

Thanks for reading this post and giving it some of your attention.

--Steve

Last edited by SteveB-in-LV; 07-01-2010 at 05:34 PM.
Reply With Quote
  #2  
Old 04-27-2010, 10:08 AM
rtb rtb is offline
VanDyke Technical Support
 
Join Date: Aug 2008
Posts: 4,306
Hi Steve,

I am sorry to hear that you are having difficulty transferring data to your Cisco device.

SecureCRT does not have a 3300 character limit to the copy and paste buffer, so this does not seem like it is the problem. I would expect that the data is being sent to the Cisco device faster than it can handle the data.

You may want to try one of the Send delay options found in the Terminal / Emulation / Advanced category of the Session Options dialog.

Does this information help you resolve the issue you are seeing?
__________________
--Todd

VanDyke Software
Technical Support
support@vandyke.com
505-332-5730

Last edited by rtb; 04-27-2010 at 04:19 PM.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 02:46 AM.