Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > File Transfer

Notices

Reply
 
Thread Tools Display Modes
  #1  
Old 03-02-2011, 12:56 AM
kleinhev kleinhev is offline
Registered User
 
Join Date: Oct 2010
Posts: 6
"Open with" not honouring selection.

When opening a (local) file in SecureFX, I right-click "Open With..." and select a program (e.g. my favorite editor) and select "Always use this program to open this type of file in SecureFX". SecureFX, however, does not remember this selection and I have to go through this process every time.

It would be nice if the option would work without changing the default Windows options.
Reply With Quote
  #2  
Old 03-02-2011, 10:19 AM
bgagnon bgagnon is offline
VanDyke Technical Support
 
Join Date: Oct 2008
Posts: 4,636
Hello kleinhev,

What version of SecureFX are you using? (Help / About SecureFX...)

When you chose 'Always use this program to open this type of file', were you presented with another dialog stating: "This extension already has an association. Do you want to change it?"

If so, and you chose Yes, is the application (your favorite editor) associated with that file type in the File Transfer / File Types category of SecureFX's Global Options?
__________________
Thanks,
--Brenda

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #3  
Old 05-16-2012, 08:20 PM
Bigwebmaster Bigwebmaster is offline
Registered User
 
Join Date: Sep 2009
Posts: 3
I have also had this problem for years with your software, just finally now looked up to see if there are any known resolutions.

I am using Version 6.7.5 (x64 build 411) - Official Release - April 19, 2012

When I choose to open with it does prompt me to "Always use this program to open this type of file", and it also does prompt me and says "This extension already has an association. Do you want to change it?". I click on yes. Then when I try to open the file it still opens in Firefox as its default. I want it to open in notepad++.

When I goto Global Options and goto File Transfer -> File Types, and scroll to the HTML extension I am trying to change, it actually says it is set to notepad++ just like it should. However when I open the file through SecureFX the default behavior still opens Firefox and note Notepad++. It is using Windows 7's default, and not SecureFX's default for that file.

I hope that helps diagnose the issue, if you have any other questions I would be happy to help. This problem has been highly annoying for me and slows down my workflow drastically.
Reply With Quote
  #4  
Old 05-17-2012, 09:43 AM
bgagnon bgagnon is offline
VanDyke Technical Support
 
Join Date: Oct 2008
Posts: 4,636
Hello Bigwebmaster,

Are you talking about local or remote file(s)?

Sorry, my prior information below was based on overlooking the customer had mentioned he was opening a local file.

The file association done within SecureFX (i.e. Global->File Transfer->File Types, Open With dialog) only apply to remote windows. The local window file associations do come from the Windows registry.
__________________
Thanks,
--Brenda

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #5  
Old 05-21-2012, 03:28 PM
Bigwebmaster Bigwebmaster is offline
Registered User
 
Join Date: Sep 2009
Posts: 3
Yes I am referring to local files. So it sounds like this is not a bug, could you turn this into a feature request then? It would be highly beneficial for me to have SecureFX use its settings versus the Windows 7 settings. The reason for that is typically when I double click on an HTML file somewhere on my computer I do want it to open up in Firefox. However, when I double click on a HTML file in SecureFX I always want it to open up in notepad++. So it is highly annoying to have to right click on the file in SecureFX and goto "Open With" every time, causes way more clicks than should be necessary and slows down my workflow.
Reply With Quote
  #6  
Old 05-22-2012, 07:56 AM
bgagnon bgagnon is offline
VanDyke Technical Support
 
Join Date: Oct 2008
Posts: 4,636
Hi Bigwebmaster,

I have added this thread to a feature request in our product enhancement database to have Open With use File Types configuration for local files. Should a future release of SecureFX include this feature, notification will be posted here.

If you prefer direct e-mail notification, contact support@vandyke.com and include "Feature Request - Forum Thread #7190" in the subject line.
__________________
Thanks,
--Brenda

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #7  
Old 05-23-2012, 06:27 AM
Olaf van der Spek Olaf van der Spek is offline
Registered User
 
Join Date: Jul 2004
Posts: 178
Maybe an Open With Text Editor command would be handy.
Reply With Quote
  #8  
Old 05-23-2012, 07:37 AM
rtb rtb is offline
VanDyke Technical Support
 
Join Date: Aug 2008
Posts: 4,305
Hi Olaf van der Spek,

I have created a feature request to add an Open With Text Editor... option to the context menu. We will post to this thread should this option be added to a future SecureFX release.
__________________
--Todd

VanDyke Software
Technical Support
support@vandyke.com
505-332-5730
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 10:19 AM.