Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > Scripting

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 11-20-2018, 01:31 AM
gabesynthesis gabesynthesis is offline
Registered User
 
Join Date: Nov 2018
Posts: 2
Exclamation SecureCRT Tools Python Script Error

Hi,

I recently had to reinstall SecureCRT along with the scripts I was using. When I try to run these scripts I now get an error message



I've checked the debug, only to find this...

<SCRIPT_INIT> Starting Logging. Running Python version: 2.7.9 (default, May 26 2016, 11:15:27) [MSC v.1800 64 bit (AMD64)]
11/20/2018 12:13:56 - <SCRIPT_INIT> Starting creation of CRTScript object
11/20/2018 12:13:56 - <SESSION_INIT> Starting creation of CRTSession object
11/20/2018 12:13:56 - <IS_CONNECTED> Checking Connected Status. Got: 1 (True)
11/20/2018 12:13:56 - <SESSION_INIT> Session already connected.
11/20/2018 12:13:56 - <IS_CONNECTED> Checking Connected Status. Got: 1 (True)

I'm not really sure what I'm missing at this point and ANY help or suggestions would be greatly appreciated!
Reply With Quote
  #2  
Old 11-20-2018, 08:59 AM
bgagnon bgagnon is offline
VanDyke Technical Support
 
Join Date: Oct 2008
Posts: 3,607
Hi gabesynthesis,

What version of SecureCRT are you using?

Just offhand that sounds like an error related to locking tabs.

Lock/Unlock functions were not available until v8.3:

Changes in SecureCRT 8.3 (Beta 1) -- September 21, 2017
-------------------------------------------------------
New features:

  • Added the ability to script session locking from the Session object.
__________________
Thanks,
--Brenda

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #3  
Old 11-20-2018, 10:27 AM
gabesynthesis gabesynthesis is offline
Registered User
 
Join Date: Nov 2018
Posts: 2
I see. I'm using v 8.1.4. I'll have to see if I can upgrade at some point.
Reply With Quote
  #4  
Old 11-20-2018, 10:55 AM
bgagnon bgagnon is offline
VanDyke Technical Support
 
Join Date: Oct 2008
Posts: 3,607
Hi gabesynthesis,

You can check upgrade eligibility here.

Basically, you would have had to have purchased (for 1-year license) on or after November 10, 2016 to be eligible to use v8.3.x. (For 3-year licenses, the issue date would have to be November 10, 2014 or later.)
__________________
Thanks,
--Brenda

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 05:07 PM.