Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > General

Reply
 
Thread Tools Display Modes
  #1  
Old 03-12-2018, 02:37 PM
jarmnah jarmnah is offline
Registered User
 
Join Date: Mar 2018
Posts: 3
Disable message - Display all nnn possibilities

In SecureCRT, I periodically see the message:
Display all nnn possibilities? (y or n)
where nnn is some number in the hundreds or thousands. I understand that these are possible options for auto-complete, but the message displays at times when I haven't done any action to request auto-complete (such as when my terminal is locked or when I'm not active in the terminal).

How can I disable the message? I do not want to disable auto-complete.
Reply With Quote
  #2  
Old 03-12-2018, 02:52 PM
ekoranyi ekoranyi is offline
VanDyke Technical Support
 
Join Date: Jan 2017
Posts: 447
Hi jarmnah,

This is not something I've seen SecureCRT do before, SecureCRT does not perform any auto-complete.

Can you provide a screenshot of the message you're seeing? Please be sure that any screenshot you provide does not contain any sensitive information.
__________________
Thanks,
--Eric

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #3  
Old 03-12-2018, 05:29 PM
jarmnah jarmnah is offline
Registered User
 
Join Date: Mar 2018
Posts: 3
I can't upload a screenshot, but this is the text from the screen:
~ $
~ $
~ $
~ $
~ $
~ $
~ $
~ $
~ $
Display all 2075 possibilities? (y or n)


If I press the TAB key twice, I get the same prompt.
Reply With Quote
  #4  
Old 03-13-2018, 08:09 AM
ekoranyi ekoranyi is offline
VanDyke Technical Support
 
Join Date: Jan 2017
Posts: 447
Hi jarmnah,

Thanks for the additional information.

Have you configured SecureCRT or another application to send anti-idle information? It sounds like there may be a configuration setup to send a tab or similar to prevent disconnecting/locking due to idle.

In SecureCRT if you navigate to Options > Session Options > Terminal is Send string enabled in the Anti-Idle category?
__________________
Thanks,
--Eric

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #5  
Old 03-13-2018, 12:28 PM
jarmnah jarmnah is offline
Registered User
 
Join Date: Mar 2018
Posts: 3
DING DING DING! I had been sending the ESC character (\033) for the anti-idle. Once I disabled it, the message stopped for that session. I tested and found that if I press ESC 3 times, the message displays. So apparently every 3rd time anti-idle sent the string, the session interpreted that as a request to autocomplete.

Thank you!
Reply With Quote
  #6  
Old 03-13-2018, 12:36 PM
ekoranyi ekoranyi is offline
VanDyke Technical Support
 
Join Date: Jan 2017
Posts: 447
jarmnah,

I'm glad to hear you found the culprit. You may get better behavior if you utilize the Send protocol NO-OP option if your remote device supports it. If NO-OP doesn't work using send string with \005 (Ctrl-E) may work for you as well.

Have a great rest of the day.
__________________
Thanks,
--Eric

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 03:11 AM.