Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > Scripting

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 10-01-2018, 06:54 PM
mike1950r mike1950r is offline
Registered User
 
Join Date: May 2018
Posts: 8
(END) Tail on status responses

Hi again,

when i ask the status of servers i have a strange issue:

for example at dovecot:
service dovecot status

i get the answer by the server and at the end:
"lines 1-22/22 (END)"

this is not on other servers, where normally the user name is prompting for next command at the end of the answer like:
root@user:~#

the problem is, when i put this last line in the command:
strResult = crt.Screen.ReadString("(END)")

then the proceeding takes really long time,
instead as if i would use the command:
strResult = crt.Screen.ReadString("root@user:~#")

then it is proceeding really fast.

why do i get this "line ... (END)" answer instead of the user prompt for next command?

what can i do that i always receive the user prompt at the end of the answer.

thanks lot for any idea.

cheers mike

ps.

forgot to say,
if this (END) statement is at the end of the answer, securecrt does not accept any commands anymore. i have to restart it.

Last edited by mike1950r; 10-01-2018 at 07:01 PM.
Reply With Quote
  #2  
Old 10-02-2018, 07:48 AM
bgagnon bgagnon is offline
VanDyke Technical Support
 
Join Date: Oct 2008
Posts: 3,557
Hello mike,

It sounds like that's server-side configuration and I'm not sure there's anything SecureCRT can do to change it.

Are you connecting to this server with SSH2 protocol?

If so, it's often useful to see trace options output which provides debugging information that may help us better understand the problem that you're experiencing.

To enable trace options output:
  • First, open SecureCRT's main File pull-down menu and select Trace Options. If you open the File pull down menu again you should see a checkmark next to Trace Options, indicating that troubleshooting output is now enabled.
  • Next, connect to the remote machine. With trace options enabled, you will notice debugging information displayed in the terminal window that isn't normally there by default when SecureCRT is attempting to establish a connection, and at certain times throughout the lifetime of the connection.
  • Once the problem occurs, please right-click inside the terminal window and choose Select All, then right-click again and choose Copy to transfer the information to the clipboard.
  • Finally, open a text editor, paste the information from the clipboard into the editor program, and save it as a text file.
Since trace options can contain sensitive information, feel free to send it as an attachment via email to support@vandyke.com. Please reference "Attn Brenda - Forum Thread #13270" in the subject line.

NOTICE: The requested troubleshooting data may include sensitive information (usernames, passwords, publicly-accessible host names or IP addresses, etc.).

Please redact sensitive information that would not be appropriate for email communication prior to sending the requested information.

If there is sensitive information that must be conveyed in order to provide a complete picture of the scenario you're facing, please let us know and we will set up a secure upload mechanism that can be used.
__________________
Thanks,
--Brenda

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 05:01 PM.