Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > File Transfer

Reply
 
Thread Tools Display Modes
  #1  
Old 11-19-2019, 03:13 AM
manish1186 manish1186 is offline
Registered User
 
Join Date: Nov 2019
Posts: 2
Japanese characters displayed as junk characters in secure FX

Issue is happening in the PeopleSoft CRM environment.

The actual process

As per the PeopleSoft delivered functionality the user can attach the attachments file through PeopleSoft online page. The attached physical file will be stored in the UNIX environment target path. The target path, actual file name information is stored in the oracle database.

The user next time, click the attachment link through PeopleSoft online page. Based on the database values like (target path and actual file name) it is opening the file without any issue.

The original file (contains Japanese character) name is “TestPdf Renamed to 360056C1R1*責処分通知書(木村明*).pdf”

Issue in the UNIX environment target path:

From SecureFX, when we see the file in the UNIX environment target path the file name is showing junk characters.

“TestPdf Renamed to 360056C1R1???????(????).pdf”

Why the file name has changed in the UNIX environment target path?
Reply With Quote
  #2  
Old 11-19-2019, 12:46 PM
berdmann berdmann is offline
VanDyke Technical Support
 
Join Date: Aug 2017
Posts: 261
Hi manish1186,

It sounds like your PeopleSoft process is completely independent of SecureFX, is that correct?

This issue is likely a character encoding problem. Try enabling the "Display filenames using UTF-8 encoding" option in Session Options. (Options > Session Options > File Transfer)



Does enabling that option resolve the issue for you?
Attached Images
File Type: png Display_UTF8.png (46.4 KB, 36 views)
__________________
Thanks,
--Brittney

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #3  
Old 11-25-2019, 04:44 AM
manish1186 manish1186 is offline
Registered User
 
Join Date: Nov 2019
Posts: 2
Quote:
Originally Posted by berdmann View Post
Hi manish1186,

It sounds like your PeopleSoft process is completely independent of SecureFX, is that correct?

This issue is likely a character encoding problem. Try enabling the "Display filenames using UTF-8 encoding" option in Session Options. (Options > Session Options > File Transfer)



Does enabling that option resolve the issue for you?


Hi,

I am using SecureCRT and secure FX of version 6.7. I ma not able to see mentioned option under file transfer.[IMG]C:\Users\AH0137046\Desktop\Option_Pic.png[/IMG]
Reply With Quote
  #4  
Old 11-25-2019, 09:03 AM
bgagnon bgagnon is offline
VanDyke Technical Support
 
Join Date: Oct 2008
Posts: 4,046
Hi manish1186,

Version 6.7 is about a decade old now!

Send an email to support@vandyke.com and include your SecureFX serial number (Help / About SecureFX) in the body of the email and we can check your eligibility for a newer version. (Make Forum Thread #13975 the subject line of the email.)

Support of UTF-8 filenames was added in v7.3:

Changes in SecureFX 7.3 (Beta 1) -- August 7, 2014
--------------------------------------------------
New features:

  • Added a new session option "Display Filenames using UTF-8 encoding" that specifies that files should always be displayed in UTF-8.

Or, you can check your eligibility here.


You might also accomplish this via an INI change:
  • Take note of config folder location in the General / Configuration Paths category of SecureFX's Global Options

  • Close all instances of SecureCRT and SecureFX

  • Go to config folder location, inside Sessions subfolder and locate session's INI (or Default.ini if it's an ad hoc connection)

  • Make the following change:
    D:"Filenames Always Use UTF8"=00000000
    to
    D:"Filenames Always Use UTF8"=00000001
  • Save changes
__________________
Thanks,
--Brenda

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730

Last edited by bgagnon; 11-25-2019 at 09:23 AM. Reason: Added INI info after verifying was in v67
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 09:30 AM.