Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > Scripting

Reply
 
Thread Tools Rate Thread Display Modes
  #16  
Old 04-04-2012, 05:20 PM
ozymandius100 ozymandius100 is offline
Registered User
 
Join Date: Feb 2012
Posts: 20
Yup. I will take a look. I think i might just be forced to install python on each machine to insure that each module works appropriately.

Oh well.....
Reply With Quote
  #17  
Old 04-05-2012, 01:57 PM
rtb rtb is offline
VanDyke Technical Support
 
Join Date: Aug 2008
Posts: 4,306
Hi ozymandius100,

I have managed to find a list of the major modules in SecureCRT's Python implementation for Windows that will not import due to missing dependencies. Hopefully this will help as you move forward with developing Python scripts for use in SecureCRT.

Code:
asynchat
asyncore
BaseHTTPServer
cgi
CGIHTTPServer
cookielib
dbhash
DocXMLRPCServer
ftplib
httplib
imaplib
macurl2path
mailbox
mimetypes
nntplib
poplib
pty
robotparser
SimpleHTTPServer
SimpleXMLRPCServer
smtpd
smtplib
socket
SocketServer
ssl
stringprep
telnetlib
tty
urllib
urllib2
_LWPCookieJar
_MozillaCookieJar
__phello__.foo
__________________
--Todd

VanDyke Software
Technical Support
support@vandyke.com
505-332-5730

Last edited by bgagnon; 06-30-2013 at 10:03 AM. Reason: corrected typo do to due
Reply With Quote
  #18  
Old 04-05-2012, 01:58 PM
ozymandius100 ozymandius100 is offline
Registered User
 
Join Date: Feb 2012
Posts: 20
Thank you very much. This will help immensely.


Quote:
Originally Posted by rtb View Post
Hi ozymandius100,

I have managed to find a list of the major modules in SecureCRT's Python implementation that will not import due to missing dependencies. Hopefully this will help as you move forward with developing scripts.

Code:
asynchat
asyncore
BaseHTTPServer
cgi
CGIHTTPServer
cookielib
dbhash
DocXMLRPCServer
ftplib
httplib
imaplib
macurl2path
mailbox
mimetypes
nntplib
poplib
pty
robotparser
SimpleHTTPServer
SimpleXMLRPCServer
smtpd
smtplib
socket
SocketServer
ssl
stringprep
telnetlib
tty
urllib
urllib2
_LWPCookieJar
_MozillaCookieJar
__phello__.foo

Last edited by bgagnon; 06-30-2013 at 10:03 AM. Reason: corrected typo in quoted material
Reply With Quote
  #19  
Old 04-05-2012, 02:15 PM
rtb rtb is offline
VanDyke Technical Support
 
Join Date: Aug 2008
Posts: 4,306
You are welcome ozymandius100.

As a note, this list may not be comprehensive.
__________________
--Todd

VanDyke Software
Technical Support
support@vandyke.com
505-332-5730
Reply With Quote
  #20  
Old 06-29-2013, 06:35 AM
yuanhaoliang yuanhaoliang is offline
Registered User
 
Join Date: Jun 2013
Posts: 3
How can I use the imaplib?
Reply With Quote
  #21  
Old 06-29-2013, 01:03 PM
yuanhaoliang yuanhaoliang is offline
Registered User
 
Join Date: Jun 2013
Posts: 3
Why I can not import imaplib using python?

I have found the "imaplib.pyc" in the python26.zip.

but when I write the "import imaplib" in the python script,

execute the script,

there is a dialog showing that

ImportError
Error: No module named _socket


how can I use the imaplib,I need the imap protocol to connect my email!!!!!
Reply With Quote
  #22  
Old 06-30-2013, 11:05 AM
bgagnon bgagnon is online now
VanDyke Technical Support
 
Join Date: Oct 2008
Posts: 4,480
Hello yuanhaoliang,

smtplib is one of the modules Todd previously listed as one that may not import correctly due to missing dependencies.

Do you know what other modules smtplib depends on being installed?
__________________
Thanks,
--Brenda

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #23  
Old 09-29-2020, 12:16 PM
bgagnon bgagnon is online now
VanDyke Technical Support
 
Join Date: Oct 2008
Posts: 4,480
Hi all,

I wanted to let you know the __socket module should be available as of SecureCRT v9.0, currently in beta 1 release, since this support was added:

Changes in SecureCRT 9.0 (Beta 1) -- September 24, 2020
-------------------------------------------------------
New Features:

  • Windows: Added support for Python 3. Python 3.8(available at python.org) must be installed and the script's first line must be: # $language = "python3". Since support for Python 3 is provided through an external module, Python 3 libraries can be used in SecureCRT scripts.

Note that this is Windows only support at this time. In fact, we released beta 1 installers *only* for Windows. We hope to include all platforms in later releases.
__________________
Thanks,
--Brenda

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 12:14 PM.