Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > General

Reply
 
Thread Tools Display Modes
  #1  
Old 09-19-2005, 12:08 PM
rolex777ru rolex777ru is offline
Registered User
 
Join Date: Sep 2005
Posts: 4
Cannot connect from SecureCRT to a remote Solaris host

It fails with the following error:

"SecureCRT has disconnected from the server. Reason: Unable to authenticate any of the configured authentication methods."

At the same time I am able to ssh to this Solaris host with no problem from my Cygwin or any other unix/linux workstation.
Reply With Quote
  #2  
Old 09-19-2005, 04:05 PM
Maureen's Avatar
Maureen Maureen is offline
VanDyke Product Director
 
Join Date: Feb 2004
Location: Albuquerque, NM
Posts: 1,612
Thanks for posting. Could you please turn on trace options and send the resulting output to support@vandyke.com? To turn on trace options, select "Trace Options" from the File menu before attempting to connect.

Maureen
Reply With Quote
  #3  
Old 09-20-2005, 08:32 AM
rolex777ru rolex777ru is offline
Registered User
 
Join Date: Sep 2005
Posts: 4
Here's the trace:
-------------------------------------

SecureCRT - Version 4.1.9 (build 278)
[LOCAL] : RECV : Remote Identifier = "SSH-2.0-OpenSSH_3.8p1"
[LOCAL] : CAP : Remote can re-key
[LOCAL] : CAP : Remote sends language in password change requests
[LOCAL] : CAP : Remote sends algorithm name in PK_OK packets
[LOCAL] : CAP : Remote sends algorithm name in public key packets
[LOCAL] : CAP : Remote sends algorithm name in signatures
[LOCAL] : CAP : Remote sends error text in open failure packets
[LOCAL] : CAP : Remote sends name in service accept packets
[LOCAL] : CAP : Remote includes port number in x11 open packets
[LOCAL] : CAP : Remote uses 160 bit keys for SHA1 MAC
[LOCAL] : CAP : Remote supports new diffie-hellman group exchange messages
[LOCAL] : CAP : Remote correctly handles unknown SFTP extensions
[LOCAL] : CAP : Remote correctly encodes OID for gssapi
[LOCAL] : CAP : Remote correctly uses connected addresses in forwarded-tcpip requests
[LOCAL] : SEND : KEXINIT
[LOCAL] : RECV : Read kexinit
[LOCAL] : Available Remote Kex Methods = diffie-hellman-group-exchange-sha1,diffie-hellman-group1-sha1
[LOCAL] : Selected Kex Method = diffie-hellman-group-exchange-sha1
[LOCAL] : Available Remote Host Key Algos = ssh-rsa,ssh-dss
[LOCAL] : Selected Host Key Algo = ssh-dss
[LOCAL] : Available Remote Send Ciphers = aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,arcfour,aes192-cbc,aes256-cbc,rijndael-cbc@lysator.liu.se,aes128-ctr,aes192-ctr,aes256-ctr
[LOCAL] : Selected Send Cipher = aes128-cbc
[LOCAL] : Available Remote Recv Ciphers = aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,arcfour,aes192-cbc,aes256-cbc,rijndael-cbc@lysator.liu.se,aes128-ctr,aes192-ctr,aes256-ctr
[LOCAL] : Selected Recv Cipher = aes128-cbc
[LOCAL] : Available Remote Send Macs = hmac-md5,hmac-sha1,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
[LOCAL] : Selected Send Mac = hmac-md5
[LOCAL] : Available Remote Recv Macs = hmac-md5,hmac-sha1,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
[LOCAL] : Selected Recv Mac = hmac-md5
[LOCAL] : Available Remote Compressors = none,zlib
[LOCAL] : Selected Compressor = none
[LOCAL] : Available Remote Decompressors = none,zlib
[LOCAL] : Selected Decompressor = none
[LOCAL] : SEND : KEXDH_GEX_REQUEST
[LOCAL] : RECV : KEXDH_GEX_GROUP
[LOCAL] : RECV : DH Prime is 1535 bits
[LOCAL] : SEND : KEXDH_INIT
[LOCAL] : RECV : KEXDH_REPLY
[LOCAL] : SEND : NEWKEYS
[LOCAL] : RECV : NEWKEYS
[LOCAL] : SEND: SERVICE_REQUEST[ssh-userauth]
[LOCAL] : RECV: SERVICE_ACCEPT[ssh-userauth] -- OK
[LOCAL] : SENT : USERAUTH_REQUEST [none]
[LOCAL] : RECV : USERAUTH_FAILURE, continuations [publickey,keyboard-interactive]
[LOCAL] : SEND: Disconnect packet: Unable to authenticate using any of the configured authentication methods.
[LOCAL] : Connected for 0 seconds, 927 bytes sent, 2446 bytes received
Reply With Quote
  #4  
Old 09-20-2005, 09:05 AM
bocks's Avatar
bocks bocks is offline
VanDyke Customer Support
 
Join Date: Jan 2004
Location: Albuquerque, NM
Posts: 184
Hi rolex777ru,
Quote:
Originally Posted by rolex777ru
Here's the trace:
-------------------------------------

SecureCRT - Version 4.1.9 (build 278)
[LOCAL] : RECV : Remote Identifier = "SSH-2.0-OpenSSH_3.8p1"
...
[LOCAL] : SEND: SERVICE_REQUEST[ssh-userauth]
[LOCAL] : RECV: SERVICE_ACCEPT[ssh-userauth] -- OK
[LOCAL] : SENT : USERAUTH_REQUEST [none]
[LOCAL] : RECV : USERAUTH_FAILURE, continuations [publickey,keyboard-interactive]
[LOCAL] : SEND: Disconnect packet: Unable to authenticate using any of the configured authentication methods.
[LOCAL] : Connected for 0 seconds, 927 bytes sent, 2446 bytes received
Thank you for sending the Trace log. What this log is showing is that the server is only accepting two forms of authentication: public key and keyboard interactive. If you are not using one of these two methods, you will not be able to authenticate, which is what this shows.

By default, SecureCRT uses the password authentication method, but the other methods are available. In your Session Options under the Connection / SSH2 category, can you check to see that keyboard interactivce is checked instead of password?

If not, can you try checking this option and let me know how it works for you?

Thank you,

-bocks
Reply With Quote
  #5  
Old 09-20-2005, 10:38 AM
rolex777ru rolex777ru is offline
Registered User
 
Join Date: Sep 2005
Posts: 4
It worked.
Thanks!
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 07:03 AM.