Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > File Transfer

Reply
 
Thread Tools Display Modes
  #1  
Old 04-19-2021, 03:08 AM
zybex zybex is offline
Registered User
 
Join Date: Apr 2021
Posts: 3
VShell resume/reput fail - locked file

Hi,
I'm using VShell v3.9 SFTP server. When trying to resume a transfer with Reput command after a connection drop, the server replies with:
'The process cannot access the file because it is being used by another process. '

The file remains locked for a long time, even disconnecting/reconnecting doesn't help. Eventually it unlocks and the resume works.

Is there a way to adjust the lock timeout on the server settings?

This only happens when there is a client connection loss (like wifi signal loss or sudden internet connection failure), so the TCP connection probably remains up for some time on the server side.

Thanks!
Reply With Quote
  #2  
Old 04-19-2021, 10:48 AM
cboyack cboyack is offline
VanDyke Technical Support
 
Join Date: Apr 2020
Location: Albuquerque, NM
Posts: 129
Hi zybex,

First off, does your VShell version 3.9 have Enable keep alives enabled under the SSH2 category in VShell's Control Panel?

This option can help the server know more quickly if the peer connection has gone down (but if there's a network component that isn't passing along that notification, as may be the case for you, then having this option enabled might not make a difference).

Quote:
Originally Posted by zybex View Post
Is there a way to adjust the lock timeout on the server settings?

Under the Common category in VShell's Control Panel, there's an option called Disconnect idle sessions after X minutes, right at the very top.

This option only has the granularity of 1 minute intervals in VShell version 3.9, so the minimum idle time that VShell can enforce in your particular situation is 1 minute.

Alternatively, if you desire to cut the idle timeout even shorter than a minute, VShell version 4.6 allows idle timeouts to be specified in seconds, rather than minutes (this option has been relocated to the SSH2 category in VShell 4.6, FYI).
__________________
Thanks,
--Cameron

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730

Last edited by cboyack; 04-19-2021 at 10:50 AM. Reason: Clarity
Reply With Quote
  #3  
Old 04-24-2021, 06:13 AM
zybex zybex is offline
Registered User
 
Join Date: Apr 2021
Posts: 3
Thanks Cameron, adjusting the timeout will probably work. Looks like it's currently set to 15 minutes which is way overkill.

I'll check if I can convince out IT dept. to upgrade to v4.6 to further adjust it to our needs.
Reply With Quote
  #4  
Old 04-27-2021, 05:11 AM
zybex zybex is offline
Registered User
 
Join Date: Apr 2021
Posts: 3
Cameron,
Can you please let me know the linux config filename and the option name to set there?
Reply With Quote
  #5  
Old 04-27-2021, 09:19 AM
cboyack cboyack is offline
VanDyke Technical Support
 
Join Date: Apr 2020
Location: Albuquerque, NM
Posts: 129
Quote:
Originally Posted by zybex View Post
Can you please let me know the linux config filename and the option name to set there?
The linux config filename is vshelld_config, and by default, is located within:
/usr/local/etc
The option name depends on the type of connection to VShell.

For SSH2 connections, the option is called SSH2IdleTimeout, and if desired to have the timeout set for 2 minutes, one could uncomment that line and edit it like so:
SSH2IdleTimeout 0

to

SSH2IdleTimeout 2m
FTPS or HTTPS connections (if needed) have similar option names called FTPSIdleTimeout and HTTPSIdleTimeout

Please also note that vshelld requires a reload (vshelld -reload) for any configuration changes to be implemented.
__________________
Thanks,
--Cameron

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
Reply

Tags
reput , resume , sftp , vshell


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 08:36 PM.