Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > SecureCRT on the Mac

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 01-29-2021, 03:17 PM
mfatty mfatty is offline
Registered User
 
Join Date: Dec 2019
Posts: 6
Session does not close/disconnect immediately when network interrupted

Let's say I have a few ssh sessions going.


Then my internet dies for a minute or my VPN disconnects or something.
SecureCRT still shows green check mark that denotes connected. But really, it's not connected because the network is down. SecureCRT has not detected that the ssh session broken. I cannot interact with the device anymore. So yes, ssh session is broken as expected. But securecrt has not closed/disconnected from the session. I don't mean close the tab/window, I mean close the TCP connection because there is no internet.


If I wait for a while, let's say after 5 minutes or so, SecureCRT will eventually detect the network interruption and disconnect/close automatically. But why does it take so long?


If I don't want to wait for 5 minutes for SecureCRT to autodetect interruption, I manually disconnect the ssh session (right click, disconnect). And then try re-connecting. Then it takes a couple of minutes trying to connect. Then reports something "Could not connect to Firewall". I think it's saying could not connect to my jumphost. Then I click on Enter and it immediately connects.



This is very disturbing because it happens quite often. Every day when I have network interruptions.



Version 8.7.3 (build 2279)
p, li { white-space: pre-wrap; }
Reply With Quote
  #2  
Old 01-29-2021, 03:45 PM
jdev's Avatar
jdev jdev is offline
VanDyke Technical Support
 
Join Date: Nov 2003
Location: Albuquerque, NM
Posts: 1,096
Hello mfatty,

If SecureCRT doesn't reflect a network disconnect in the status of an open tab/tile/connection, it is because the operating system's TCP/IP stack hasn't yet provided SecureCRT with any notification of the connection having gone down.

If you want to accelerate the ability to have a downed connection be detected more quickly in SecureCRT, open your session options, navigate to the Terminal category and enable the anti-idle Send protocol NO-OP option; specify how many seconds you'd like to wait at a minimum.
Note that when the connection is good, this will mean that SecureCRT will be sending packets unnecessarily, but if you don't want SecureCRT to be beholden to notifications from the operating system, this one way to work around the OS failing to provide timely notification of a TCP connection having gone down.
Make this change to both your jump host session and other sessions and see how well things work for you.

Let us know what you discover.

--Jake
__________________
Jake Devenport
VanDyke Software
Technical Support
YouTube Channel: https://www.youtube.com/vandykesoftware
Email: support@vandyke.com
Web: https://www.vandyke.com/support
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 11:02 AM.