Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > General

Closed Thread
 
Thread Tools Display Modes
  #1  
Old 07-08-2019, 04:32 PM
bgagnon bgagnon is offline
VanDyke Technical Support
 
Join Date: Oct 2008
Posts: 4,048
Arrow How-To: Install SecureCRT on Ubuntu 19.04

When your favorite OS has released a new version, but it is not yet officially supported by SecureCRT (or not a platform we build on at all), oftentimes if you are adventurous enough and you don't have any problems running unsupported software on your system and living with any subsequent problems that you might encounter, you might be able to get SecureCRT working.

Below is a set of steps that may help you get SecureCRT installed on Ubuntu 19.04:
Code:
# Open a native Terminal app (Ctrl+Alt+T) and run these commands...
# Switch to super user (root) context:
sudo su -

# Change directory to the location where the scrt
# installer .deb file was saved.
# (instead of "user" in this command, type in your
# user account name -- the one that downloaded
# SecureCRT; and if you downloaded the .deb file to
# a location different from 'Downloads', specify
# that folder.)
cd ~user/Downloads

# Download the libssl1.0.0 library:
wget http://security.ubuntu.com/ubuntu/pool/main/o/openssl1.0/libssl1.0.0_1.0.2n-1ubuntu5.3_amd64.deb

# Install the libssl1.0.0 library:
dpkg -i libssl1.0.0_1.0.2n-1ubuntu5.3_amd64.deb

# Install python2.7 library:
apt-get -y install libpython2.7

# Install SecureCRT using the downloaded .deb file:
dpkg -i scrt-sfx-8.5.4-1942.ubuntu18-64.x86_64.deb

# Exit back to 'user' context:
exit

# Launch SecureCRT as 'user'
SecureCRT&
And here are the commands without comments:
  1. sudo su -
  2. cd ~user/Downloads
  3. wget http://security.ubuntu.com/ubuntu/pool/main/o/openssl1.0/libssl1.0.0_1.0.2n-1ubuntu5.3_amd64.deb
  4. dpkg -i libssl1.0.0_1.0.2n-1ubuntu5.3_amd64.deb
  5. apt-get -y install libpython2.7
  6. dpkg -i scrt-sfx-8.5.4-1942.ubuntu18-64.x86_64.deb
  7. exit
  8. SecureCRT&
__________________
Thanks,
--Brenda

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730

Last edited by bgagnon; 10-30-2019 at 11:08 AM. Reason: Was not made a sticky and fixed header to match
Closed Thread

Tags
.deb , dpkg , faq , how-to , install , libpython , libssl , ubuntu 19


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 05:51 PM.