Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > File Transfer

Reply
 
Thread Tools Display Modes
  #1  
Old 06-28-2019, 03:09 PM
ups_scs_team ups_scs_team is offline
Registered User
 
Join Date: Jun 2019
Posts: 4
Unable to use SFXCL with password having special characters

Environment: Windows 2008 Server R2

Problem:

We are using VBS to transfer files to an SFTP server using SFXCL. The password has special characters such as "&" and "#". When this SFXCL command is fired using this password, it fails to connect. The error logged is "Hostname lookup failed. Format error, connection refused, or not implemented."

We tried escaping the special characters in the password by using hexadecimal equivalent. However, it did not help.

Note that this same password works through SecureFX client.

We also attempted using URL encoding function to send the password, and that did not help either.

We thus request your help to resolve this problem.

Thank you!!
Reply With Quote
  #2  
Old 06-28-2019, 03:14 PM
ups_scs_team ups_scs_team is offline
Registered User
 
Join Date: Jun 2019
Posts: 4
Unable to use SFXCL with password having special characters

SFXCL version being used is 8.0
Reply With Quote
  #3  
Old 06-28-2019, 04:33 PM
berdmann berdmann is offline
VanDyke Technical Support
 
Join Date: Aug 2017
Posts: 207
Hi ups_scs_team,

In order to troubleshoot this issue, I will need to collect information from you that is not suitable for the forums.

Please send an email to support@vandyke.com, with ATTN: Brittney, Forum Thread# 13607 in the subject field.

Can you please include your SecureFX serial number in the email (Help > About SecureFX)?

I would also like to compare trace logs from your successful connection using the SecureFX GUI and the failure case using SFXCL.

To generate the trace log for your success case, please navigate to Options -> Global Options -> File Transfer -> Advanced in SecureFX and enable the "Enable log output to file" option. Once you have successfully enabled the option, specify a location and name for the file. Please refer to the following example:
After enabling logging you will want to connect to the same remote host that you are connecting to with SFXCL via the GUI application to generate the trace log. Please attach the trace log of your successful connection to the email to support.


In order to generate a trace log for the failure case using SFXCL you will need to add the "/Log" command-line option, followed by the path/filename of the desired log-file to your SFXCL command. For example:

Code:
SFXCL.exe /S /Headquarters /Log c:\DebugLog.txt /Policies/Mission.txt "c:\My Documents\Presentation.txt"
Running your SFXCL command with the /Log command-line option will generate the trace log of your failed connection. Please attach the trace log of your failed SFXCL attempt to the email to support.

Please do not post your serial number or any trace log data in the forums!!!
Attached Images
File Type: png SFX_LogFileOption.png (56.1 KB, 36 views)
__________________
Thanks,
--Brittney

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #4  
Old 07-01-2019, 09:12 AM
ups_scs_team ups_scs_team is offline
Registered User
 
Join Date: Jun 2019
Posts: 4
Log files sent

Thank you, Brittany for your quick response! We have emailed the logs according to your instructions to the email address mentioned in your response.
We look forward to hearing from you.

Thanks.
Reply With Quote
  #5  
Old 07-01-2019, 10:42 AM
berdmann berdmann is offline
VanDyke Technical Support
 
Join Date: Aug 2017
Posts: 207
Hi ups_scs_team,

Did you have a chance to send the logs to support@vandyke.com? I did not receive them.

In general, usernames/passwords that include "@" or ":" or other special characters as part of the username/password are passed on the command line, the command will fail by default because these characters have special meanings to the command shell. The user must substitute those symbols with the hexadecimal equivalent for the command to succeed.

The hexadecimal equivalents to these special characters are as follows:
Code:
  Char     Hex Code
  -------  --------
  [space]    %20
     "       %22
     #       %23
     $       %24
     %       %25
     &       %26
     '       %27
     (       %28
     )       %29
     *       %2A
     +       %2B
     ,       %2C
     -       %2D
     .       %2E
     /       %2F
     :       %3A
     ;       %3B
     <       %3C
     =       %3D
     >       %3E
     ?       %3F
     @       %40
     \       %5C
     ^       %5E
     `       %60
     |       %7C
For example, if my username was starflyer and my password was:

Code:
@%//\\:*
...then I would specify the command line as follows:

sfxcl sftp://starflyer:%40%25%2F%2F%5C%5C%3A%2A@hostname/path

Is this information helpful?
__________________
Thanks,
--Brittney

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #6  
Old 07-01-2019, 02:47 PM
ups_scs_team ups_scs_team is offline
Registered User
 
Join Date: Jun 2019
Posts: 4
Email with Logs

Hello Brittany,

We did send an email with log files attached couple of hours ago. It was sent from svedire@gmail.com.

Let us know if you still have not received these.

We are using hexadecimal characters to substitute the special characters, similar to the way to mention.

Thanks.
Reply With Quote
  #7  
Old 07-01-2019, 05:23 PM
berdmann berdmann is offline
VanDyke Technical Support
 
Join Date: Aug 2017
Posts: 207
Hi ups_scs_team,

I did receive the logs that you sent the second time!

I have responded to your email.
__________________
Thanks,
--Brittney

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
Reply

Tags
ftp , password


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 07:03 AM.