VanDyke Software Forums

Go Back   VanDyke Software Forums > File Transfer
User Name
Password
Register FAQ Members List Calendar Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
  #1  
Old 01-05-2017, 07:10 AM
EricS EricS is offline
Registered User
 
Join Date: Jun 2016
Posts: 4
VShell sftp: user not going to virtual root

SFTP from unix to Windows, user can connect and browse to the proper folder but does not start in that folder on connection. The "use single virtual root" option is enabled.

I'm sure I'm missing something obvious but I can't find it.
Reply With Quote
  #2  
Old 01-05-2017, 07:42 AM
bgagnon bgagnon is offline
VanDyke Technical Support
 
Join Date: Oct 2008
Posts: 2,856
Hi EricS,

Quote:
SFTP from unix to Windows, user can connect and browse to the proper folder but does not start in that folder on connection. The "use single virtual root" option is enabled.
That is exactly the designed behavior when Use single virtual root is enabled.

See this tip on our website. If you disable that option, you should get the desired behavior.
__________________
Thanks,
--Brenda

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #3  
Old 01-05-2017, 08:05 AM
EricS EricS is offline
Registered User
 
Join Date: Jun 2016
Posts: 4
Quote:
Originally Posted by bgagnon View Post
If you disable that option, you should get the desired behavior.
It doesn't seem to make any difference. I've set the virtual root to a directory off the F: drive, added the requisite user to the Access control list and verfied the access is allowed. Whether the "user single virtual root" option is enabled or disabled the result is:

#[root@sourceserver:.ssh] ssh username@targetserver

Microsoft Windows [Version 6.3.9600]
(c) 2013 Microsoft Corporation. All rights reserved.

C:\Users\username\Documents>

I set up another server yesterday with the same username and path and it worked. So I'm sure I'm just missing something
Reply With Quote
  #4  
Old 01-05-2017, 08:08 AM
bgagnon bgagnon is offline
VanDyke Technical Support
 
Join Date: Oct 2008
Posts: 2,856
Hi EricS,

It sounds like you failed to remove the Everyone group from the <Unrestricted> virtual root. When a user has multiple virtual roots configured, they will land in the first one (top to bottom as shown in the list), in this case the Unrestricted root (which does resolve to the Documents folder). Please investigate this possibility.
__________________
Thanks,
--Brenda

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #5  
Old 01-05-2017, 09:05 AM
EricS EricS is offline
Registered User
 
Join Date: Jun 2016
Posts: 4
Looked at that item, no groups listed under the Unrestricted virtual root. I even added the Everyone group and then removed it again. No apparent difference.
Reply With Quote
  #6  
Old 01-05-2017, 09:11 AM
bgagnon bgagnon is offline
VanDyke Technical Support
 
Join Date: Oct 2008
Posts: 2,856
Hi EricS,

A colleague just pointed out that you are using a shell client (ssh user@host), not an SFTP client (sftp user@host). Virtual roots only restrict SFTP access.

What are the results when an SFTP client is used?
__________________
Thanks,
--Brenda

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #7  
Old 01-05-2017, 10:07 AM
EricS EricS is offline
Registered User
 
Join Date: Jun 2016
Posts: 4
The results were success and me banging my head on the desk.

Silly error, and nice catch. Thanks.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 05:10 PM.


copyright 1995-2015 VanDyke Software, Inc.