Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > General

Reply
 
Thread Tools Display Modes
  #1  
Old 01-28-2011, 03:01 PM
kgaudineer kgaudineer is offline
Registered User
 
Join Date: Jan 2011
Posts: 15
Using CTRL characters....

I am a new user to SecureCRT. I am trying to get all of my support techs to stop using hyperterm and move to SecureCRT as one of our support tools. A large part of our job is to attach a serial cable to a device so we can configure it or trouble shoot it. Our hardware platform requires that when we first attach to a device we need to press a key combination before we are alowed access. That key combo is CTRL+Y. I have found that when using a serial cable connection I cant get the CTRL+Y key combo to work so we keep having to go back to hyperterm. Is ther a way to setup SecureCRT to send CTRL+Y when we press the CTRL+Y keys on the keyboard?
Reply With Quote
  #2  
Old 01-28-2011, 04:29 PM
bgagnon bgagnon is offline
VanDyke Technical Support
 
Join Date: Oct 2008
Posts: 4,352
Hello kgaudineer,

This is likely not a keymap issue, so much as you have not matched the parameters for the serial connection.

In HyperTerm, please verify baud rate (bps), data bits, parity, stop bits and flow control from the COM port properties.

Then be certain in the 'Connection / Serial' category of SecureCRT's Session Options that you are matching these parameters.

If Flow Control is "None" in HyperTerm, you would want the three options "Disabled" in SecureCRT (RTS/CTS is enabled by default).

Once you have matched SecureCRT's configuration to the one you use in HyperTerm, what are the results when you send Ctrl+Y?
__________________
Thanks,
--Brenda

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #3  
Old 09-29-2011, 01:00 PM
miked's Avatar
miked miked is offline
Registered User
 
Join Date: Feb 2004
Posts: 2,040
We just spoke with a customer experiencing the same problem, where Ctrl-Y was apparently not being sent when using Serial protocol to connect to an Avaya switch. As Brenda suggested, flow control was the problem. The solution was to enable XON/XOFF flow control in Session Options / Connection / Serial. We also disabled RTS/CTS, but that may not be required.

Is anyone else able to confirm that XON/XOFF is the solution?
__________________
Mike
VanDyke Software
Technical Support
[http://www.vandyke.com/support]

Last edited by miked; 09-29-2011 at 03:30 PM.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 05:03 AM.