Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > File Transfer

Notices

Reply
 
Thread Tools Display Modes
  #1  
Old 01-24-2016, 07:07 AM
verint verint is offline
Registered User
 
Join Date: Jan 2016
Posts: 3
Thumbs up Running "Substitute User" from SecureFX

Hi,
i would like to run a SU command & remmber passwords.

But I have the following issues:

1. In secureFX tools > Substitute user is grayed out.
2. In Session Options > logon actions > automate logon is also grayed out
3. In Session Options connection > local shell command is grayed out

How can I enable?
Thanks,
Yariv
Reply With Quote
  #2  
Old 01-25-2016, 07:47 AM
bgagnon bgagnon is offline
VanDyke Technical Support
 
Join Date: Oct 2008
Posts: 4,636
Hi Yariv,

Very timely.

See this related post.

Do you have a terminal emulation application, such as SecureCRT, available to you?
__________________
Thanks,
--Brenda

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730

Last edited by bgagnon; 01-25-2016 at 02:07 PM. Reason: Link to another post was incorrect
Reply With Quote
  #3  
Old 01-27-2016, 02:10 AM
verint verint is offline
Registered User
 
Join Date: Jan 2016
Posts: 3
Yes, I am also using SecureCRT.
I have looked in the thread so my first question is not possible.

What about:
2. In Session Options > logon actions > automate logon is also grayed out
3. In Session Options connection > local shell command is grayed out

They are also grayed out in SecureCRT
Reply With Quote
  #4  
Old 01-27-2016, 07:34 AM
bgagnon bgagnon is offline
VanDyke Technical Support
 
Join Date: Oct 2008
Posts: 4,636
Hi Yariv,

Quote:
2. In Session Options > logon actions > automate logon is also grayed out
I am not sure what you mean because that option is a checkbox. If you want to enter lines into the Expect/Send fields, you would enable Automate logon and then edit/enter the lines as needed.

Quote:
3. In Session Options connection > local shell command is grayed out
What version of SecureCRT are you running?

In the current release, v7.3.6, Local shell command is just a label that appears over top of the Pre-connect field.

What are you trying to accomplish?
__________________
Thanks,
--Brenda

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #5  
Old 01-27-2016, 11:51 PM
verint verint is offline
Registered User
 
Join Date: Jan 2016
Posts: 3
2. the automate logon check-box is grayed-out.

3. version 7.3.6 (x64 build 963)
Sorry meant the Pre-connect is grayed out.
What I wanted is to run "sudo su -" before I connect to have permissions, but in any case this is not possible as we so in question 1.

So only #2 is left.

Thanks
Reply With Quote
  #6  
Old 01-28-2016, 08:31 AM
bgagnon bgagnon is offline
VanDyke Technical Support
 
Join Date: Oct 2008
Posts: 4,636
Hi Yariv,

Is your inquiry in #2 with respect to SecureCRT or SecureFX?

If SecureCRT, please explain what you would like to do in the Logon Actions category. As previously explained, if you want to "automate logon", then you would enable that option and fill in the Expect/Send fields. (You would probably also want to enable Display logon prompts in terminal window.)

A typical use case for this is to automate the logon process *and* if desired, also send some commands once the connection is authenticated.

If the inquiry is regarding SecureFX, this is not available because SecureFX is not a *shell application*, it's a secure file transfer application.
__________________
Thanks,
--Brenda

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 06:22 AM.