Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > Secure Shell

Reply
 
Thread Tools Display Modes
  #1  
Old 04-30-2006, 04:17 AM
balubeto balubeto is offline
Registered User
 
Join Date: Apr 2006
Posts: 4
SSH2 connection, Server X.Org and normal account

HI

I have two computer in one LAN.

On the first computer, I have XP with the client SecureCRT 5.1.0 and the client TightVNC.

On second computer, I have Linux Debian Etch Testing with the server OpenSSH, server X.Org and the server x11VNC.

Now, I would want to make to start and to control the server X.Org on a Linux normal account from the first computer with one SSH2 connection. How it is made to make that?

THANKS

HI
__________________
Balubeto
Reply With Quote
  #2  
Old 05-01-2006, 11:10 AM
miked's Avatar
miked miked is offline
Registered User
 
Join Date: Feb 2004
Posts: 2,040
Can you provide a few more details about what you're wanting to do?

Taking a guess, it sounds like maybe you're wanting to display an X session on your XP client, and have the X11 data sent via a port forward. If you're wanting to do this, you will need an X11 server running on the XP client, and in SecureCRT enable Forward X11 Packets in Session Options / Connection / Port Forwarding / Remote/X11.
__________________
Mike
VanDyke Software
Technical Support
[http://www.vandyke.com/support]
Reply With Quote
  #3  
Old 05-02-2006, 09:11 AM
balubeto balubeto is offline
Registered User
 
Join Date: Apr 2006
Posts: 4
I have executed your instructions but, if I acces with a Linux normal account, this appears me:

Quote:
Using username "balubeto".
Authenticating with public key "imported-openssh-key"
Linux PLUTO 2.6.15-1-686 #2 Mon Mar 6 15:27:08 UTC 2006 i686

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
You have new mail.
Last login: Thu Apr 20 17:53:38 2006 from pippo
balubeto@PLUTO:~$ startx &
[1] 6095
balubeto@PLUTO:~$ xauth: creating new authority file /home/balubeto/.serverauth.6095

X: user not authorized to run the X server, aborting.
giving up.
/usr/X11R6/bin/xinit: Connection refused (errno 111): unable to connect to X server
/usr/X11R6/bin/xinit: No such process (errno 3): Server error.
Couldnt get a file descriptor referring to the console

[1]+ Exit 71 startx
balubeto@PLUTO:~$
How never?

THANKS

BYE
__________________
Balubeto
Reply With Quote
  #4  
Old 05-02-2006, 05:04 PM
miked's Avatar
miked miked is offline
Registered User
 
Join Date: Feb 2004
Posts: 2,040
Is your Windows XP computer running an X11 server?

If so, can you run a command such as the following and get anything to display in the X server window on Windows XP?
balubeto@PLUTO:~$ xeyes &
Is the server where VShell is running added to xhost list as per the information provided in SecureCRT Help?

To find the X11 information in SecureCRT Help, open the Help menu / Help topics / Search tab. Search for "x forwarding" and select Port Forwarding with SSH.

Are you wanting to run an entire X Session over the tunnel, or could you run specific clients over the tunnel?

Performance might be a little bit faster if you only run specific clients.

If you're logged onto the Linux Debian server (PLUTO) as user balubeto, at the console, are you able to run the startx command successfully?
__________________
Mike
VanDyke Software
Technical Support
[http://www.vandyke.com/support]
Reply With Quote
  #5  
Old 05-09-2006, 08:59 PM
aihtdikh aihtdikh is offline
Registered User
 
Join Date: May 2006
Posts: 1
Hey balubeto,

I had the same problem attempting to start X on my Debian Etch box over ssh;
the problem is not caused by SecureCRT but by the default X security settings.
For Debian, there is a config file /etc/X11/Xwrapper.config, which by default
is set to allow only local (console) users to start the X server.
If you change the line
allowed_users=console
to
allowed_users=anybody
then you can run startx over an ssh connection.
(Of course, do not do this if you have other people logging into your machine
over ssh).
The other thing is, from what I understand of your setup, you could just set the
linux computer to start x on boot and log you in automatically (using gdm or kdm),
then connect to it with vnc - that way you never have to run startx manually.

Anyway, I hope it helps, and have fun

aiht
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 11:56 AM.