Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > Secure Shell

Reply
 
Thread Tools Display Modes
  #16  
Old 12-24-2009, 11:18 AM
maxg maxg is offline
Registered User
 
Join Date: Dec 2009
Posts: 22
Trajan Pro is an Adobe font that was installed with the Master Suite/Photoshop.

SecureCRT was literally the first program I installed after the Windows 7 Ultimate install, and I noticed the issue immediately.

I'm going to spend some more time on it and see if I can't figure it out.
Reply With Quote
  #17  
Old 12-24-2009, 02:30 PM
maxg maxg is offline
Registered User
 
Join Date: Dec 2009
Posts: 22
Huzzah! I figured it out.

After reading http://msdnrss.thecoderblogs.com/200...t-dynamics-gp/

I started looking into how Windows sets the OEM_FIXED_FONT constant, and found some interesting registry entries.

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\GRE_Initialize\SmallFont lists the actual .fon files Windows uses for various things.

After getting a friend to send me an export of their GRE_Initialize registry folder, I noticed the difference of "OEMFONT.FON"="vga850.fon" (on mine) and "OEMFONT.FON"="vgaoem.fon" on theirs. Changed the key, rebooted and all is well. The one true font has been restored.

For anyone else who has this problem, here's a .reg you can use to fix the default fonts in Windows 7.

Code:
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\GRE_Initialize]
"DisableRemoteFontBootCache"=dword:00000000
"LastBootTimeFontCacheState"=dword:00000000

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\GRE_Initialize\LargeFont]
"FIXEDFON.FON"="8514fix.fon"
"FONTS.FON"="8514sys.fon"
"OEMFONT.FON"="8514oem.fon"

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\GRE_Initialize\SmallFont]
"FIXEDFON.FON"="vgafix.fon"
"FONTS.FON"="vgasys.fon"
"OEMFONT.FON"="vgaoem.fon"
Thanks for all your help Mike, I apologize for thinking this was a SecureCRT issue, I hope I didn't waste too much of your time!
Reply With Quote
  #18  
Old 12-24-2009, 05:18 PM
miked's Avatar
miked miked is offline
Registered User
 
Join Date: Feb 2004
Posts: 2,040
Quote:
I'm going to spend some more time on it and see if I can't figure it out.

Huzzah! I figured it out.
That's great! Thanks for posting your solution and the link!
__________________
Mike
VanDyke Software
Technical Support
[http://www.vandyke.com/support]
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 10:41 AM.