Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > SecureCRT on the Mac

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 08-29-2018, 02:25 PM
soezticle soezticle is offline
Registered User
 
Join Date: Aug 2018
Posts: 2
Secure CRT is slow / Laggy

It's not the connect time, a dns issue, or some networking thing.
There's just a noticeable slowness to the application compared to using a standard terminal shell.

For example:
on my mac's terminal i used 'cat' to output a 1.5Megabyte file
real 0m1.183s
user 0m0.001s
sys 0m0.012s


but the same thing from secure crt:
real 0m17.487s
user 0m0.001s
sys 0m0.023s

The text file has 17,667 lines of text.
The difference of 17K lines in 1.1 seconds vs 17 is significant.
Is there something I can do to speed this up, get a more realtime output speed?
Reply With Quote
  #2  
Old 08-29-2018, 04:18 PM
jdev's Avatar
jdev jdev is offline
VanDyke Technical Support
 
Join Date: Nov 2003
Location: Albuquerque, NM
Posts: 836
Hello soezticle,

If you enable the Minimize Drawing option in the Terminal category of your session options, do you get faster scrolling performance?



Do you have keyword highlighting enabled? (Session Options, Terminal > Appearance category)

What is the size of your scrollback buffer? (Session Options, Terminal > Emulation category)

Is your session configured to be logging output to a file (Session Options, Terminal > Log File category)?

Is your session currently running a python script for any automation? (check the main Script menu in SecureCRT, if the Cancel menu item is enabled, then a script is running)

--Jake
Attached Images
File Type: png SCRT_Mac_Terminal_MinimizeDrawing.png (84.2 KB, 133 views)
__________________
Jake Devenport
VanDyke Software
Technical Support
support@vandyke.com
http://www.vandyke.com/support
Reply With Quote
  #3  
Old 08-30-2018, 08:30 AM
soezticle soezticle is offline
Registered User
 
Join Date: Aug 2018
Posts: 2
Initially, minimize drawing was not enabled.
I tried enabling it and there isn't a noticeable difference.

I checked scrollback, it was 500 lines.
Tried changing it to 0, still not really noticeable.

I am logging, tried disabling, no difference.

Not running any python scripts.


I compared with my terminal settings.
That app is using infinite scrollback and transparency is enabled. Graphically speaking my terminal is asking for a lot more graphics processing and memory than securecrt and it's still beating it by far.

I'm on an imac with a gpu in it. Does securecrt not utilize gpu or something?
Reply With Quote
  #4  
Old 08-30-2018, 11:41 AM
berdmann berdmann is offline
VanDyke Technical Support
 
Join Date: Aug 2017
Posts: 74
Hi soezticle,

I am sorry to hear that the behavior did not improve with the suggested configuration settings!

I have asked our QA/Dev team to investigate the behavior.

Should any improvements be made, we will be sure to post here to let you know!
__________________
Thanks,
--Brittney

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #5  
Old 09-14-2018, 09:25 AM
berdmann berdmann is offline
VanDyke Technical Support
 
Join Date: Aug 2017
Posts: 74
Hi soezticle,

I heard back from our Dev team regarding the slow scrolling behavior that you reported. They would like to know what version of SecureCRT are you currently running?

You can determine the version by navigating to "SecureCRT" (main menu) > About SecureCRT.
__________________
Thanks,
--Brittney

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 2 (0 members and 2 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 08:12 AM.