Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > Scripting

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 09-05-2018, 10:17 AM
rmedlin rmedlin is offline
Registered User
 
Join Date: Sep 2018
Posts: 2
Pop up box interferes with logon script

Hi,

I apologize if this posts twice but I finished the original post and didn't see it.

I'm using SecureCRT 3.4 on a Windows Server 2003 box. I know.

The server is due to be decommissioned soon, but in the mean time, I need an alert to show that a particular program is running. The e-mail portion is fine and the logon portion works except for one problem.

In our version of SCRT, right before the logon finishes, a pop up appears that says "This system is for authorized users..." etc. You have to click OK or press Enter to close it.

I've tried a variety of ways to close that pop up (I assume it's a message box. It doesn't look like a form) via scripting including SendKeys or Send with:

- "{ENTER]"
- ~
- Chr(13)
- VbCr
- \r
- "%N"

Nothing has worked so far. It it a problem with lost focus? I don't know. It's one of those tiny little problems that drives you crazy and may have a obvious solution that I'm missing.

Any assistance would be greatly appreciated.
Reply With Quote
  #2  
Old 09-05-2018, 11:48 AM
jdev's Avatar
jdev jdev is offline
VanDyke Technical Support
 
Join Date: Nov 2003
Location: Albuquerque, NM
Posts: 836
SecureCRT 3.4

That takes me way way way back to the days of yore when I started working here at VanDyke Software as a "Code Ranger"...
It's impressive that SecureCRT 3.4 has been chugging along for you for so long... but I digress!

SecureCRT v3.4's scripting capabilities will not help you solve this problem, unfortunately. The pop-up you're seeing is likely the auth banner prompt sent to SecureCRT from the server to which you're connecting. The auth banner appears before you have the opportunity to complete authentication while script execution begins/resumes after authentication has been completed.

In 4.1 and later versions, SecureCRT began displaying the auth banner message as text within the terminal window, rather than in a pop-up requiring interaction. Upgrading to version 4.1 or newer would be the solution. To determine if your license is eligible for registering version 4.1, check your license's issue date to see if it's in the range listed in the upgrade eligibility chart for legacy products online on our web site. Unfortunately, support for Windows 2003 was dropped a while ago, so the most recent version of SecureCRT you can run on that platform would be 7.3.7.

More at issue is that since you're on a server version of Windows, where terminal services is present, a specific license agreement is required in order to run SecureCRT in terminal server or Citrix type environments. Please reach out to our licensing department by email to request authorization to use SecureCRT in a Windows Server environment: licensing@vandyke.com.

--Jake
__________________
Jake Devenport
VanDyke Software
Technical Support
support@vandyke.com
http://www.vandyke.com/support
Reply With Quote
  #3  
Old 09-06-2018, 10:03 AM
rmedlin rmedlin is offline
Registered User
 
Join Date: Sep 2018
Posts: 2
Okay, then. Since the banner appears to be coming from the SunOS, I found that there is a way to log on in quiet mode (-q) that supposedly suppresses that banner.

If I pass this string to the SecureCRt Connect method:

cmd = "/SSH2 /L " & user & " /PASSWORD " & passwd & " /C 3DES /M MD5 " & host

Is there a way I can add that "-q" flag to that string?
Reply With Quote
  #4  
Old 09-06-2018, 10:34 AM
jdev's Avatar
jdev jdev is offline
VanDyke Technical Support
 
Join Date: Nov 2003
Location: Albuquerque, NM
Posts: 836
Quote:
Originally Posted by rmedlin View Post
Is there a way I can add that "-q" flag to that string?
No. SecureCRT doesn't support a "-q" flag.

SecureCRT is not the same as OpenSSH, nor is either one implemented using any components of the other.

I've already provided the only solution I'm aware of on the client side.

There may be the possibility of configuring the SunOS SSH server to NOT send the auth banner, but that is something you'll need to do in concert with the SSH2 server folks on the SunOS machine.

--Jake
__________________
Jake Devenport
VanDyke Software
Technical Support
support@vandyke.com
http://www.vandyke.com/support
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 08:36 AM.