Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > General

Notices

Reply
 
Thread Tools Display Modes
  #1  
Old 11-10-2006, 02:22 AM
stakk stakk is offline
Registered User
 
Join Date: Nov 2006
Posts: 1
Color Setup / Terminal Emulation?

Hi all,

I am currently evaluating several SSH clients for windows.
SecureCRT looks the best, but I have some problmes with setting colors and the right terminal.

The main thing I do is connecting to Linux boxes via SSH2.

I have no idea how I should set everything up. I want it to look like puTTY, but this is what I get in e.g. yast2:

puTTY:


Secure CRT vt100:


SecureCRT xterm ANSI:


Any hints?

Thank you
stakk
Reply With Quote
  #2  
Old 11-10-2006, 11:18 AM
tnygren's Avatar
tnygren tnygren is offline
Registered User
 
Join Date: May 2005
Posts: 1,408
Hi Stakk,

Thanks for the screen shots!

It appears that the line drawing settings in SecureCRT need to be changed to allow the correct characters to be displayed.

To most common settings that allow the line characters to be displayed correct are to set the 'Font' to 'Courier New', the 'Character encoding' to 'OEM' or 'Default' and the 'Use Unicode line drawing characters' option should be enabled in the 'Appearance' sub-category under 'Terminial' in the 'Session Options'.

Does changing these settings allow the line drawing characters to appear correctly?
__________________
Thanks,

Teresa

Teresa Nygren
Reply With Quote
  #3  
Old 11-21-2006, 08:10 AM
uncle.f uncle.f is offline
Registered User
 
Join Date: Nov 2006
Posts: 1
Hello,

I have exactly the same problem.
The above mentioned settings do not change anything :-(
Reply With Quote
  #4  
Old 11-21-2006, 09:27 AM
tnygren's Avatar
tnygren tnygren is offline
Registered User
 
Join Date: May 2005
Posts: 1,408
Hi Uncle.f,

Which emulation is the session set to use?

If it is set to VT100 in the 'Emulation' sub-category under 'Terminal' in the 'Session Options', does setting it to 'Xterm' provide better results?

If not, could you provide me with a raw log for this session showing the incorrect line drawing?

To create a raw log:

1. Before connecting with the session, select Raw Log Session from CRT's File menu.

2. In the Select Log File dialog, choose a folder and filename in which you would like the log text to be stored and click the Save button. At this point, if you open the File menu, you will notice that Raw Log Session now has a check-mark next to it; this indicates that raw logging is activated.

3. Now connect to the remote machine and perform the actions which cause the reported problem to occur.

4. Disconnect the session and select Raw Log Session from the File menu to turn off the raw log feature.

5. Browse to the location of the raw log file and attach it to your reply.

Once captured, please send this raw log to me via email. Just send it to support@vandyke.com with a subject of ATTN: Teresa Forum Thread 1887.
__________________
Thanks,

Teresa

Teresa Nygren
Reply With Quote
  #5  
Old 11-21-2006, 03:19 PM
mekanik mekanik is offline
Registered User
 
Join Date: Jul 2005
Posts: 46
Another option might be to use "Terminal" as your font setting?
Session Options >> Terminal >> Appearance >> Normal Font

/mekanik/
Reply With Quote
  #6  
Old 11-21-2006, 04:03 PM
tnygren's Avatar
tnygren tnygren is offline
Registered User
 
Join Date: May 2005
Posts: 1,408
Hi Uncle.f,

I did receive your latest email response and I wanted to post the solution that worked in this case.

In case anyone else is experiencing this issue with Yast, using Xterm as the emulation will allow the correct line drawing characters to be displayed.
__________________
Thanks,

Teresa

Teresa Nygren
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 02:29 PM.