Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > Scripting

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 04-16-2006, 04:36 AM
salgio salgio is offline
Registered User
 
Join Date: Apr 2006
Posts: 3
Log session

Hi everyone.

I have a problem. If i start five different session in five tab in the same window, with the following command line:

securecrt /s "lxweb001" /s "lxweb002" /s "lxweb003" /s "lxccw001" /s
"lxccw002"

i can get only to start log session only for the last one, though in the ini file for each session, the parameter

D:"Start Log Upon Connect"

is set to "1".

I think this is a softawre bug, are you agree?

Thanks for answers!
Reply With Quote
  #2  
Old 04-17-2006, 06:00 AM
miked's Avatar
miked miked is offline
Registered User
 
Join Date: Feb 2004
Posts: 2,040
Hi!

What does your Log file entry box say (Session Options / Terminal / Log File category)?

If you set it to something such as as C:\Temp\%H.log, so that each log file name is unique, are you able to log each session?
__________________
Mike
VanDyke Software
Technical Support
[http://www.vandyke.com/support]
Reply With Quote
  #3  
Old 04-18-2006, 01:09 AM
salgio salgio is offline
Registered User
 
Join Date: Apr 2006
Posts: 3
In each ini file the log path is set right. For instance, the linux server session called "lxccw001" has the follwing parameter:

S:"Log Filename"

set to

C:\temp\log\%Y%M%D%S.log

and so on for the other sessions

If i open each session in a separate tab, using the menu command "file" and "connect", i can get each session to start right logging, in five separate log file.

If i start the five session with a single command line like this:

securecrt.exe /s "lxweb001" /s "lxweb002" /s "lxweb003" /s "lxccw001" /s
"lxccw002"

I can get the session to start in a separate tab correct, but the log session will be active only for the last one, the first four session will have the log session off.


This is a true mistery!!

If you want, you can replicate this situation, and you will see that there is a bug.

Thanks a lot.
Reply With Quote
  #4  
Old 04-18-2006, 06:24 PM
miked's Avatar
miked miked is offline
Registered User
 
Join Date: Feb 2004
Posts: 2,040
I was able to duplicate the problem with SecureCRT 5.0, but not with SecureCRT 5.1. With version 5.1 all of the log files are created regardless of how many sessions I start, when using the /S option.

Which version of SecureCRT are you using (Help / About SecureCRT...)?
__________________
Mike
VanDyke Software
Technical Support
[http://www.vandyke.com/support]

Last edited by miked; 04-18-2006 at 09:24 PM.
Reply With Quote
  #5  
Old 04-19-2006, 06:23 AM
salgio salgio is offline
Registered User
 
Join Date: Apr 2006
Posts: 3
I have the 5.0 version. Thanks a lot for your advice!!



Quote:
Originally Posted by miked
I was able to duplicate the problem with SecureCRT 5.0, but not with SecureCRT 5.1. With version 5.1 all of the log files are created regardless of how many sessions I start, when using the /S option.

Which version of SecureCRT are you using (Help / About SecureCRT...)?
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 06:16 PM.