Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > File Transfer

Reply
 
Thread Tools Display Modes
  #1  
Old 10-11-2017, 07:04 AM
shannonphillips shannonphillips is offline
Registered User
 
Join Date: Oct 2017
Posts: 4
vsftp lcd not working with network drives

I'm using vsftp and the lcd command only allows me to change the folder on my local harddrive c:\whereever\
If I try to point to a file share like:
lcd \\servername\sharedfolder\
it does not work like other ftp programs allow
Reply With Quote
  #2  
Old 10-11-2017, 08:05 AM
bgagnon bgagnon is offline
VanDyke Technical Support
 
Join Date: Oct 2008
Posts: 3,098
Hi shannonphillips,

It sounds like you are using a fairly recent version of ClientPack (vsftp). A change was made in version 8.0 requiring certain characters (that are valid for use in filenames on Unix/Linux systems) to be *escaped* by a backslash. Therefore, you need another backslash for each one used in your UNC path:

lcd \\\\servername\\sharedfolder\\
__________________
Thanks,
--Brenda

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #3  
Old 10-11-2017, 12:21 PM
shannonphillips shannonphillips is offline
Registered User
 
Join Date: Oct 2017
Posts: 4
Question Thanks, That fixed next issue rm command with wildcards

Is there a better more detail support URL with these tricks other than https://www.vandyke.com/products/vsh...w_of_vsftp.htm

Now I'm trying to use rm command to delete all files in the remote folder like *.xls
Reply With Quote
  #4  
Old 10-11-2017, 01:18 PM
bgagnon bgagnon is offline
VanDyke Technical Support
 
Join Date: Oct 2008
Posts: 3,098
Hi shannonphillips,

What syntax are you using?

What are the results?

Are you getting an error? If so, what's the error?
__________________
Thanks,
--Brenda

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #5  
Old 10-12-2017, 07:16 AM
shannonphillips shannonphillips is offline
Registered User
 
Join Date: Oct 2017
Posts: 4
vsftp rm command

After doing a cd to set the path and get --move *.xls to get all the files, I've tried the following to delete them:
rm *.xls
rm path *.xls

Both return the error "The system cannot find the file specified."
Reply With Quote
  #6  
Old 10-12-2017, 07:25 AM
bgagnon bgagnon is offline
VanDyke Technical Support
 
Join Date: Oct 2008
Posts: 3,098
Hello shannonphillips,

I am not sure what you mean by "get --move *.xls". That is not a valid vsftp command. If the files have been *moved* (by mv command), then they would not exist on the remote system to be deleted and so the error you are getting is exactly right.

If not already logging the entire session (--log vsftplog.txt), please add that option to the vsftp command-line and post the log of the session.

Or, if it contains sensitive data, attach to email sent to support@vandyke.com. (Include "Attn Brenda - Forum Thread #12856" in the subject line.)
__________________
Thanks,
--Brenda

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #7  
Old 10-12-2017, 09:03 AM
bgagnon bgagnon is offline
VanDyke Technical Support
 
Join Date: Oct 2008
Posts: 3,098
Hi shannonphillips,

I have to reverse myself on part of last post. As shown in attachment, there is a --move option available to the get command. However, the result is the same since --move does a move operation (deletes each source file after it has been successfully transferred).



So rm results are exactly right. The files are no longer there to be removed.
Attached Images
File Type: png forumthread12856.png (17.0 KB, 12 views)
__________________
Thanks,
--Brenda

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730

Last edited by jdev; 10-12-2017 at 09:41 AM.
Reply With Quote
  #8  
Old 10-13-2017, 08:17 AM
shannonphillips shannonphillips is offline
Registered User
 
Join Date: Oct 2017
Posts: 4
Smile Resolved

ok, there must have been some cache issue with using FileZilla at the same time, the move command is working correctly.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 11:24 AM.