Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > General

Reply
 
Thread Tools Display Modes
  #1  
Old 01-31-2011, 09:26 AM
iorr61 iorr61 is offline
Registered User
 
Join Date: Jan 2011
Posts: 2
Pipe Remapped To Tilde

Simple one, I'll assume... Frequently, the pipe "|" remaps to the tilde "~" key when I'm in Cisco devices. Seems like it's the only key that changes. Looking for the cause and fix.

Thanks!
Reply With Quote
  #2  
Old 01-31-2011, 10:13 AM
miked's Avatar
miked miked is offline
Registered User
 
Join Date: Feb 2004
Posts: 2,040
Hello iorr61,

I'm not sure that's an easy one to solve, from a SecureCRT perspective. Maybe there's an easy fix within the Cisco device. It sounds like the Cisco devices you're connecting to are responding to a pipe by echoing back a tilde. In SecureCRT you could map a key, but you need to know what key to send instead. For example, do you just need to swap the tilde and pipe keys? If so, it's a peculiar fix and I'd think there may be a more satisfactory fix within the device itself.

Are you only getting these results with certain Cisco devices?

Do you get different results if you use a different terminal emulator?

Would you send trace options output to support@vandyke.com with a subject line of Attn Mike forum thread 7040?

To enable trace options output:

First, open SecureCRT's main "File" pull-down menu and select "Trace Options". If you open the "File" pull down menu again you should see a checkmark next to "Trace Options", indicating that troubleshooting output is now enabled.

Next, connect to the remote machine. With trace options enabled, you will notice debugging information displayed in the terminal window that isn't normally there by default when SecureCRT is attempting to establish a connection, and at certain times throughout the lifetime of the connection.

Once the problem occurs, please right-click inside the terminal window and choose "Select All", then right-click again and choose "Copy" to transfer the information to the Windows clipboard.

Finally, open a text editor like 'Notepad', paste the information from the Windows clipboard into the editor program, save it as a text file, then send it as an e-mail attachment.
__________________
Mike
VanDyke Software
Technical Support
[http://www.vandyke.com/support]
Reply With Quote
  #3  
Old 06-20-2011, 02:11 PM
iorr61 iorr61 is offline
Registered User
 
Join Date: Jan 2011
Posts: 2
Red face Solved

Michael, Thanks for the feedback, but I've solved my problem. I have the UK keyboard enabled on my computer, so when I paste in one of my sessions, I hit ctrl before shift, instead of at the same time, which is a shortcut to rotate between keyboards. The ~ on the UK keyboard layout is the | on the US keyboard. I'd be surprised if no one else has accidentally done the same.

Alan.
Reply With Quote
  #4  
Old 06-20-2011, 02:21 PM
bgagnon bgagnon is offline
VanDyke Technical Support
 
Join Date: Oct 2008
Posts: 4,359
Hello iorr61,

Michael is out of the office today.

We are glad to hear you were able to resolve the keymap issue.

Thanks for posting your solution for other members in the forums.
__________________
Thanks,
--Brenda

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #5  
Old 03-17-2013, 08:10 PM
nigelmcguinness nigelmcguinness is offline
Registered User
 
Join Date: Feb 2009
Posts: 1
Thankyou very much iorr61,

I had the same problem.
So I changed my keyboards in Control panel to only use US
and the PIPE went back to being a PIPE again.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 10:07 PM.