Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > Secure Shell

Reply
 
Thread Tools Display Modes
  #1  
Old 07-31-2018, 10:52 AM
corp-mule corp-mule is offline
Registered User
 
Join Date: Mar 2006
Posts: 18
How do I stop the PAM pop up window?

Hi,

When I login to *SOME* routers from our *nix box, I get a pop up box that just says "PAM Authentication" and "OK." No other options. It appears to be informational only, because it has an icon with the letter "i" on it.


I use the same *nix box to login to all the devices (routers and switches, etc). But here's the thing ... it does not happen on *all* devices I login to.

How do I stop it?

I used the global options "default sessions" to ensure all the sessions are configured the same. But it continues to happen.

Thanks.
Reply With Quote
  #2  
Old 07-31-2018, 12:18 PM
berdmann berdmann is offline
VanDyke Technical Support
 
Join Date: Aug 2017
Posts: 63
Hi corp-mule,

In order to figure out if/how you can disable the pop-up box, we must first determine where the it is coming from.

Can you please send an email to support@vandyke.com ("Attn Brittney - Forum Thread #13199"* in the subject line) with the following information:

1. Can you please attach a trace options log from one of the sessions exhibiting the behavior?
  • Launch SecureCRT and open SecureCRT's main "File" menu and select the "Trace Options" menu item.
  • Open the "File" menu again and choose "Log Session..." --> Specify a path to your Desktop folder and a name of the log file, such as SCRT_Log.txt. For example: %APPDATA%\..\..\Desktop\SCRT_Log.txt
  • Now attempt your connection again.
  • When the connection fails, open SecureCRT's "File" menu and look at the "Log Session" menu item. If it has a check-mark next to it, click on it to turn off logging.
  • Go to your Desktop folder and locate the SCRT_Log.txt file. Please send the SCRT_Log.txt file to me as an attachment to your reply. Please don't paste the contents into the body of your message -- please attach it!

2. Can you please also attach a screenshot depicting the behavior?

3. In order to determine where in the trace output that the pop-up box appears can you please provide the last line that you see in the terminal when the pop-up box appears?
__________________
Thanks,
--Brittney

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #3  
Old 08-01-2018, 04:36 PM
corp-mule corp-mule is offline
Registered User
 
Join Date: Mar 2006
Posts: 18
RESOLVED !!!

I found the issue.

In the session options, under
> Connection
> logon Actions

In the section at the bottom called "SSH1/SSH2," is a check box that says ...

"Display logon prompts in terminal window"

This option was enabled in some sessions but not in others.

When it is enabled, the informational pop up box for PAM does not happen. Instead, a PAM message is displayed in the terminal window.

Thanks!
Reply With Quote
  #4  
Old 08-01-2018, 04:42 PM
berdmann berdmann is offline
VanDyke Technical Support
 
Join Date: Aug 2017
Posts: 63
Hi corp-mule,

I am happy to hear that you were able to find a work-around that provides you with more desirable behavior!

Please let us know if you have any additional questions moving forward!
__________________
Thanks,
--Brittney

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 12:12 PM.