Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > General

Notices

Reply
 
Thread Tools Display Modes
  #1  
Old 10-31-2016, 07:12 AM
lells lells is offline
Registered User
 
Join Date: Oct 2016
Posts: 8
Secure CRT on Linux servers

Hi,

I've tried to source this information on the web and in the forum search, and have so far come up with nothing of use.

I have an annoying issue whereby the Directory listing in Linux (RedHat 6+ flavours) displays with a green background, and flashing red writing. This doesn't happen using other emulators such as 'PuTTY', so I'm wondering if there is a setting somewhere that I am missing?

TIA
Reply With Quote
  #2  
Old 10-31-2016, 09:18 AM
bgagnon bgagnon is offline
VanDyke Technical Support
 
Join Date: Oct 2008
Posts: 4,633
Hello lells,

What version of SecureCRT are you using?

What is the emulation configuration in the Terminal / Emulation category of Session Options? Is ANSI Color also checked in this category?

I would expect you would see the same results as Putty if SecureCRT is configured with Xterm emulation and ANSI Color is enabled as that is Putty's default configuration. (Note that an emulation change requires a disconnect/reconnect.)
__________________
Thanks,
--Brenda

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #3  
Old 10-31-2016, 09:22 AM
lells lells is offline
Registered User
 
Join Date: Oct 2016
Posts: 8
Thanks for the prompt response, Brenda.

The CRT version is 7.2.6 (bosses won't allow me upgrades), and the settings are based on the above, as that's the only thread I've been able to find on the subject. It's been an annoyance for a long time now, but I've kind of lived with it. Just thought I'd ask the question on the off chance anyone has solved it previously.

I've tried messing with the 'Cursor Blinking' settings and other display settings, on the off-chance they may be causing it, but to no avail.
Reply With Quote
  #4  
Old 10-31-2016, 02:10 PM
bgagnon bgagnon is offline
VanDyke Technical Support
 
Join Date: Oct 2008
Posts: 4,633
Hi lells,

Quote:
I have an annoying issue whereby the Directory listing in Linux (RedHat 6+ flavours) displays with a green background, and flashing red writing. This doesn't happen using other emulators such as 'PuTTY', so I'm wondering if there is a setting somewhere that I am missing?
Without revealing any sensitive data, could you post a screenshot showing this issue? Obviously you won't be able to capture the flashing activity, but I'll assume all red text is flashing.
__________________
Thanks,
--Brenda

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #5  
Old 11-01-2016, 04:27 AM
lells lells is offline
Registered User
 
Join Date: Oct 2016
Posts: 8
Caught it at just the right time, the text, as you see, is in a 'flash state', therefore you can't see it.

Reply With Quote
  #6  
Old 11-01-2016, 12:16 PM
bgagnon bgagnon is offline
VanDyke Technical Support
 
Join Date: Oct 2008
Posts: 4,633
Hi lells,

With ANSI Color enabled, the special effects you see means SecureCRT is receiving an escape sequence (that it is honoring) that defines those effects. If you enabled raw logging before running the ls command, I believe you would see [5;31;42m before each entry, which translates to:

5 -- flashing text
31 -- red (text)
42 -- green background

There's likely an LS_COLORS environment variable (di is the directory config option) on the remote system responsible for your results. There also could be an entry in your ~/.bashrc file on the remote system. You would need to edit or create the appropriate entry according to how you would like these entries displayed. Here's an article we found useful in explaining those results.

My best guess as to your Putty results is that it is just ignoring the escape sequences.
__________________
Thanks,
--Brenda

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #7  
Old 11-01-2016, 12:21 PM
lells lells is offline
Registered User
 
Join Date: Oct 2016
Posts: 8
Thanks for the response. I am aware of the settings, I was just curious as to why CRT seems to interpret it when other applications don't. I was kind of hoping there was a way around it without having to change the LS_COLOURS on around 700 servers. Unfortunately, I'm the only one in the company that uses CRT, due to some legacy software we have knocking around that doesn't work in puTTY (and I secretly think it's massively better than puTTY).

It's an annoyance, but one that's plagued me for the last 9 or so years since we introduced Linux over AIX. Hey ho.

E2a, for reference, puTTY displays the dir listing with the same colours, but minus the annoying flashing.

Last edited by lells; 11-01-2016 at 12:23 PM.
Reply With Quote
  #8  
Old 11-01-2016, 02:16 PM
bgagnon bgagnon is offline
VanDyke Technical Support
 
Join Date: Oct 2008
Posts: 4,633
Hi lells,

What is the most annoying thing about it?

The flashing text? Or the colors?

I think you could resolve the red/green by editing the ANSI Color blocks via the Terminal / Appearance / ANSI Color category in Session Options. I changed both the red and green under Normal colors to the same as non-colored text (gray on black). I can't find a workaround for the flashing though.

Or, you could just disable ANSI Color.
__________________
Thanks,
--Brenda

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #9  
Old 11-02-2016, 04:31 AM
lells lells is offline
Registered User
 
Join Date: Oct 2016
Posts: 8
The flashing is the more annoying part as it makes it difficult to see. I do like the colours, I'm a big fan of the colour differentiation in directory listings and vim, so i don't really want to go down the route of disabling the colour options completely.
Reply With Quote
  #10  
Old 11-02-2016, 08:02 AM
bgagnon bgagnon is offline
VanDyke Technical Support
 
Join Date: Oct 2008
Posts: 4,633
Hi lells,

Good to know. I think you can prevent the flash, by disabling blink where it's associated with the color scheme.
  • In Session Options, go to Terminal / Appearance category

  • Choose Edit... button next to current color scheme

  • Disable Enable blink
Depending on what color scheme you are using, it may change your background / foreground colors but through the same dialog you can edit them to again reflect the desired colors.
__________________
Thanks,
--Brenda

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #11  
Old 11-04-2016, 09:13 AM
lells lells is offline
Registered User
 
Join Date: Oct 2016
Posts: 8
Hi,

Sorry for the delay replying, it's been a hectic old week.

Unfortunately that didn't make any difference, the blinking occurs regarding of the state of the 'disable blinking' switch.
Reply With Quote
  #12  
Old 11-04-2016, 01:04 PM
bgagnon bgagnon is offline
VanDyke Technical Support
 
Join Date: Oct 2008
Posts: 4,633
Hi lells,

I think we missed an important step.

Is Use color scheme enabled in the Terminal / Emulation category of Session Options?

It has to be for you to be able to disable blink. It's when you enable Use color scheme that your colors will likely switch and you will have to edit foreground / background colors to get back to what was shown in the screenshot you included.

So InitialXtermANSI.png attached illustrates what I expect your display looks like.

From there, you would take these steps:
  • Enable Use color scheme, now it should look like XtermANSIUsecolorscheme.png attached.

  • Edit Monochrome color scheme in Terminal / Appearance category:
  • Disable Enable blink if not already disabled
  • Change foreground to Gray* and background to Black
  • Should result in display shown in EditedColorScheme.png
*From what I can tell, the original color of the text before changes is a gray with RGB values of 192 for each.
Attached Images
File Type: png editedColorScheme.png (6.4 KB, 408 views)
File Type: png XtermANSIUsecolorscheme.png (6.5 KB, 578 views)
File Type: png initialXtermANSI.png (6.2 KB, 391 views)
__________________
Thanks,
--Brenda

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #13  
Old 11-07-2016, 03:32 AM
lells lells is offline
Registered User
 
Join Date: Oct 2016
Posts: 8
Absolutely brilliant. You have just become my new hero. You must don a cape and wear your underwear outside of clothes, from here on. Thank you so very much. Now to figure out how to apply this to all my sessions.

Thanks again.
Reply With Quote
  #14  
Old 11-07-2016, 11:55 AM
jdev's Avatar
jdev jdev is offline
VanDyke Technical Support
 
Join Date: Nov 2003
Location: Albuquerque, NM
Posts: 1,099
Quote:
Now to figure out how to apply this to all my sessions.
Use the force, Obi-Wan...

You can employ the power (force) of editing the Default session to make these changes to all of your existing and future sessions. Here are some links to a tip and a video that provide more details about using the Default session to make mass changes to multiple sessions:
https://www.vandyke.com/support/tips/defaultset.html
https://www.youtube.com/watch?v=5RbuZn9L48g
--Jake
__________________
Jake Devenport
VanDyke Software
Technical Support
YouTube Channel: https://www.youtube.com/vandykesoftware
Email: support@vandyke.com
Web: https://www.vandyke.com/support
Reply With Quote
  #15  
Old 11-09-2016, 11:37 AM
lells lells is offline
Registered User
 
Join Date: Oct 2016
Posts: 8
Great stuff, all sorted, sessions are now all in order, and Lee is a very happy bunny. Really appreciate your speedy and concise responses. A credit to your team. If only all support departments could be as efficient (our own included for our products )

Many thanks, you can consider this issue resolved.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 04:05 PM.