Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > Secure Shell

Notices

Reply
 
Thread Tools Display Modes
  #1  
Old 07-05-2006, 09:55 AM
JeffLangford JeffLangford is offline
Registered User
 
Join Date: Jul 2006
Posts: 1
Vshell Home

Hi there,

I am using VShell 2.6.2 (build 417) on windows 2003. I am also using VShell Version 2.3.3 (build 217) on Windows 2000. On the 2000 machine, everything works fine. On the 2003 machine, I have a problem. When I login (using WS-FTP) I see all the drive letters and the alias (/SFTP) which I configured. I have very carefully copied all the permissions, users and configurations between the machine that works and the one that doesn't.

Is there an issue on Windows 2003 that causes this? Am I missing a configuration setting somewhere?

After some tinkering with the file permissions some more I have solved the drive letters but what I see when I login is the Alias I created. When I click the Alias I get to where I really want to get to.

Thanks
Jeff Langford
Reply With Quote
  #2  
Old 07-26-2006, 05:51 PM
Maureen's Avatar
Maureen Maureen is offline
VanDyke Product Director
 
Join Date: Feb 2004
Location: Albuquerque, NM
Posts: 1,612
Sorry for the slow reply. I'm not sure why aliases aren't working correctly for you under Windows 2003. I have logged an issue in our development database so that we can look into it.

Maureen
Reply With Quote
  #3  
Old 07-28-2006, 03:39 PM
Chris Chris is offline
VanDyke Developer
 
Join Date: May 2004
Location: Albuquerque, NM
Posts: 13
Hello Jeff,

I would like to get a little more information about the problem you are experiencing with VShell 2.6.2.

If I understand correctly, when users connect to the server using sftp, you only want them to have access to the sftp root alias you have created (/sftp). And, you expect them to end up in that folder upon connection. Is this the behavior you expect to see?

If that is the case, there are a couple of steps you will need to take. To restrict access to the entire file system for sftp connections, open the VShell Control Panel and go to the 'SFTP' page. Highlight the "<Unrestricted>" sftp root and click on the edit button. By default, the 'Everyone' group has unrestricted access, so you will want to highlight that group and click the "Toggle access" button, which will change the access to 'Deny'. At this point, users should no longer see any drive letters.

In order for the user to end up inside the sftp root you have configured, there is a registry only option that will need to be turned off. Open regedit and browse to HKEY_LOCAL_MACHINE\Software\VanDyke\VShell\Server. There will be an option under this key called "Sftp Use Single Virtual Root" The value of this option will need to be set to 0. With this option turned off, the users should now end up inside the /sftp alias when they connect.

Do you get the behavior you are looking for after making these changes?

Thanks,
Chris
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 08:23 PM.