Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > Secure Shell

Reply
 
Thread Tools Display Modes
  #1  
Old 11-18-2005, 10:04 AM
bahaerol bahaerol is offline
Registered User
 
Join Date: Nov 2005
Posts: 1
SecureCRT 5.0 cursor problem

> We have a problem as following:
>
> We have used SecureCRT 5.0 for 4 months. We oftenly use this software
> for connecting unix systems. If we create a session for one of our
> unix server and set the connection type SSH2. We can login the system and work without a problem. At that session we want to use ftp protocol. However at ftp protocol command prompt the backspace caracter does not work. It does not clear the text.
> Instead it sweep over the characters without erasing them.
> Also the cursor cuntinues over the prompt characters after the command characters if i continue pressing backspace.
> If we use telnet protocol in order to connect to the unix system again via SecureCRT 5.0, there is no problem as above.
>
> We have tried to change some backspace related configurations of
> session for SSH2 connection but we could not reach a solution. By the way, also sqlplus command prompt have the similar problem.

does anyone have an idea about this problem

best regards..

bahaerol
Reply With Quote
  #2  
Old 01-08-2006, 10:39 AM
kkoehle kkoehle is offline
Registered User
 
Join Date: Jan 2006
Posts: 1
Here is fix.

Here is a fix.

Go to Session Options.
Go to Mapped Keys
Map a Key - choose Backspace Key...
Use the Send String Function.
Fill in this for the string: \010\040\010

Hit okay and you are done.

Good luck
Reply With Quote
  #3  
Old 01-09-2006, 06:29 PM
FuzzyFox's Avatar
FuzzyFox FuzzyFox is offline
Registered User
 
Join Date: Feb 2005
Location: Dallas, TX
Posts: 59
Send a message via ICQ to FuzzyFox Send a message via AIM to FuzzyFox Send a message via MSN to FuzzyFox Send a message via Yahoo to FuzzyFox
Question

What interest me most here is that you are using the same program (SecureCRT) but you get different behaviors with different protocols. That is very VERY strange.

I believe this could result from some terminal-driver problems on your Unix server. When you use telnet, you end up with a terminal that is served via telnetd. When you use ssh, you use a terminal provided by sshd. It could be that these two daemons do not set up the terminal the same way.

It would be interesting to compare the output of the stty -a command using both protocols (telnet, and ssh).

P.S. Mapping the backspace key to send backspace-space-backspace is not a "fix."
Reply With Quote
  #4  
Old 12-12-2006, 05:46 PM
ddjones70 ddjones70 is offline
Registered User
 
Join Date: Dec 2006
Posts: 5
Angry Definately not a fix

Adding the mapped key does not help, only appears to help. ASCII codes are being left which are unseen which creates other issues. An example: ftp. Even though it looks as though you have backspaced what you typed, ftp client will not recognize the command typed. This is the same for sqlplus which makes the whole endeavor pointless We have just recently purchesed many licenses of SecureCRT and would like to see this resoved.

Regards,
Daniel J.
AIX Systems Administrator
Reply With Quote
  #5  
Old 12-12-2006, 06:32 PM
miked's Avatar
miked miked is offline
Registered User
 
Join Date: Feb 2004
Posts: 2,040
Quote:
...the backspace caracter does not work. It does not clear the text.
Instead it sweep over the characters without erasing them.
Quote:
It would be interesting to compare the output of the stty -a command using both protocols (telnet, and ssh).
Can you run stty -a in a telnet and an SSH connection and show the output?

As I recall, an stty setting of "-echoe" can cause the problematic backspace behavior you're describing.
__________________
Mike
VanDyke Software
Technical Support
[http://www.vandyke.com/support]
Reply With Quote
  #6  
Old 12-13-2006, 11:10 AM
ddjones70 ddjones70 is offline
Registered User
 
Join Date: Dec 2006
Posts: 5
Output from stty -a

We are running a mix of IBM AIX 4.3, 5.2 & 5.3

This was run from a system running AIX 5.3

Here is the output from stty -a

speed 9600 baud; 24 rows; 80 columns;
eucw 1:1:0:0, scrw 1:1:0:0:
intr = ^C; quit = ^\; erase = ^?; kill = ^U; eof = ^D; eol = ^@
eol2 = ^@; start = ^Q; stop = ^S; susp = ^Z; dsusp = ^Y; reprint = ^R
discard = ^O; werase = ^W; lnext = ^V
-parenb -parodd cs8 -cstopb hupcl cread -clocal -parext
-ignbrk brkint ignpar -parmrk -inpck -istrip -inlcr -igncr icrnl -iuclc
-ixon -ixany -ixoff imaxbel
isig icanon -xcase echo echoe echok -echonl -noflsh
-tostop echoctl -echoprt echoke -flusho -pending iexten
opost -olcuc onlcr -ocrnl -onocr -onlret -ofill -ofdel tab3
Reply With Quote
  #7  
Old 12-13-2006, 01:09 PM
jjh jjh is offline
VanDyke Customer Support
 
Join Date: Feb 2004
Posts: 819
Hello ddjones70

i'm not sure what you mean when you say that ASCII codes are
being left behind.

What codes do you see being left behind?

Can you explain what you mean by this and provide an
example:

Quote:
An example: ftp. Even though it looks as though you
have backspaced what you typed, ftp
client will not recognize the command
typed.
Does pressing Ctrl+H backspace over characters the way you
want?

Thank you

JJH
Reply With Quote
  #8  
Old 12-27-2006, 02:35 PM
ddjones70 ddjones70 is offline
Registered User
 
Join Date: Dec 2006
Posts: 5
Unhappy Backspace behaviour in SQL*Plus

Control + H does work, but not they way we need it to work. It does erase the character, but leaves the character on-screen (i.e. pressing ^H, the cursor will move as though you pressed the Lft-Arrow). We need it to not only erase the character, but to also erase the character from the terminal screen, just like it does when you are not in SQLplus, i.e. the regular terminal.

As a note: Putty 0.58 does work correctly without even modifying any of the default settings.

Last edited by ddjones70; 12-27-2006 at 02:37 PM.
Reply With Quote
  #9  
Old 12-27-2006, 02:39 PM
miked's Avatar
miked miked is offline
Registered User
 
Join Date: Feb 2004
Posts: 2,040
If you enable Backspace sends delete in Session Options / Terminal / Emulation / Mapped Keys, does it help?
__________________
Mike
VanDyke Software
Technical Support
[http://www.vandyke.com/support]
Reply With Quote
  #10  
Old 12-27-2006, 02:43 PM
ddjones70 ddjones70 is offline
Registered User
 
Join Date: Dec 2006
Posts: 5
Exclamation Backspace behaviour in SQL*Plus

Not at all, it does the opposite now, the cursor stays still (but in reality it does erase the characters) and leaves the characters on screen.

Even changed stty to include as a test:

stty erase '^H'

That allows the SQLPlus to backspace almost correctly (erases the character, but not from the screen), but in doing so, screws up the normal terminal session backspace functionality (i.e. doesn't backspace at all, just enters the following "^?" instead.

Last edited by ddjones70; 12-27-2006 at 02:45 PM.
Reply With Quote
  #11  
Old 12-27-2006, 02:58 PM
miked's Avatar
miked miked is offline
Registered User
 
Join Date: Feb 2004
Posts: 2,040
I think there are stty settings on the server that should be changed, but I'm not sure which stty setting to change. The man page for stty helps some but not enough. I would expect stty echoe to fix the problem but you already have it set.

In SecureCRT if you map the Backspace key to send \011 do you get better results?

To map it:
  • Open Session Options / Terminal / Emulation / Mapped Keys.
  • Click the Map a Key button.
  • Press Backspace.
  • Select Send String as the Function and enter \011 as the Send String.
__________________
Mike
VanDyke Software
Technical Support
[http://www.vandyke.com/support]
Reply With Quote
  #12  
Old 12-27-2006, 03:00 PM
ddjones70 ddjones70 is offline
Registered User
 
Join Date: Dec 2006
Posts: 5
That \011 looks like it's sending a tab. Now the backspace does not work at all.
Reply With Quote
  #13  
Old 12-27-2006, 03:06 PM
miked's Avatar
miked miked is offline
Registered User
 
Join Date: Feb 2004
Posts: 2,040
Sorry, I meant \010. You may have answered this question above. We received your e-mail message. We'll respond via e-mail and post the solution here later.
__________________
Mike
VanDyke Software
Technical Support
[http://www.vandyke.com/support]

Last edited by miked; 01-03-2007 at 06:19 PM.
Reply With Quote
  #14  
Old 07-04-2014, 08:24 AM
chandanetce chandanetce is offline
Registered User
 
Join Date: Jul 2014
Posts: 1
Smile

Here is Your Complete solution-

1. Go to session Option
2. Go to Default Session
3. Click on 'Edit default Settings...'
4. Under 'Mapped Key' , Check mark on 'Backspace Sends delete'.


You Are Done.........

Hope this will help You..........
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 03:13 PM.