Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > General

Reply
 
Thread Tools Display Modes
  #1  
Old 06-05-2018, 04:42 AM
tip tip is offline
Registered User
 
Join Date: Jun 2018
Posts: 2
SecureCRT on linux (openSUSE)

Hello!

I'm trying to install securecrt on my openSUSE 15...
I downloaded a rpm file for RedHat from the download page
To provide necessary dependencies i created symlinks:

Code:
ln -s /usr/lib64/libcrypto.so.1.0.0 /usr/lib64/libcrypto.so.10
ln -s /usr/lib64/libssl.so.1.0.0 /usr/lib64/libssl.so.10
But when i'm tryind to launch SecureCrt i see errors:
Code:
SecureCRT: /usr/lib64/libssl.so.10: version `libssl.so.10' not found (required by SecureCRT)
SecureCRT: /usr/lib64/libcrypto.so.10: version `libcrypto.so.10' not found (required by SecureCRT)
Any ideas how i can fix it or it's impossible to launch SecureCrt on openSUSE
Reply With Quote
  #2  
Old 06-05-2018, 08:14 AM
bgagnon bgagnon is offline
VanDyke Technical Support
 
Join Date: Oct 2008
Posts: 3,423
Hi tip,

I have created a feature request on your behalf in our product enhancement database to port SecureCRT to OpenSUSE 15 (64-bit Linux). Should a future release of SecureCRT include this feature, notification will be posted here.

If you prefer direct email notification, send an email to support@vandyke.com and include "Feature Request - Forum Thread #13135" in the subject line or use this form from the support page of our website.

The steps you have taken has generally been the workaround that customers have shared with us explaining how they got SecureCRT installed/running on unsupported platforms although the path to the libraries was slightly different (just /lib64, not /usr/lib64 because installed as root I assume).

Quote:
If you're on OpenSUSE, you might be able to get SecureCRT to function and work for you if you perform these steps:

1) Download the RHEL7 RPM installer for SecureCRT.

2) As root, install SecureCRT from the command line:
zypper install scrt-8.3.3-1646.rhel7-64.x86_64.rpm
--> When you see the dependency issue raised as "Problem: nothing provides libcrypto.so.10()(64bit) needed by scrt-8.3.3-1646-x86_64", choose the 'Solution 2: break scrt-8.3.3... by ignoring some of its dependencies' and complete the installation

3) Link up the libcrypto and libssl libraries on your system so that SecureCRT can load/find/use them:
ln -s /lib64/libcrypto.so.1.0.0 /lib64/libcrypto.so.10
ln -s /lib64/libssl.so.1.0.0 /lib64/libssl.so.10

Although SecureCRT isn't yet officially supported on OpenSUSE, using the above strategy you may still be able to run it and use it with a high level of success.
__________________
Thanks,
--Brenda

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #3  
Old 06-05-2018, 09:04 AM
tip tip is offline
Registered User
 
Join Date: Jun 2018
Posts: 2
Hi bgagnon,

I did everything according your instructions but i still get the same errors

Code:
SecureCRT: /usr/lib64/libssl.so.10: version `libssl.so.10' not found (required by SecureCRT)
SecureCRT: /usr/lib64/libcrypto.so.10: version `libcrypto.so.10' not found (required by SecureCRT)
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 05:11 PM.