Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > SecureCRT on the Mac

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 05-13-2019, 06:05 AM
Azim Azim is offline
Registered User
 
Join Date: May 2019
Posts: 1
Unwanted character appends on passing commands to exe using SecureCRT

I am using SecureCRT Version 8.5.3 (x64 build 1867) for one of my project. I have created console application which can take command as argument.

On the basis on command passed, the application will perform certain operation. But some time even I am passing correct command to application, the SecureCRT appends some unwanted character to the command due to that application not able to identify the command.
e.g:
ftp> MyApplication.exe –Test
output: -Test[4~[C[C[C[C[4~[C[C[C[CHFGHFJGH

The above ‘–Test’ command now having unwanted symbols, it can be vary every time.
Reply With Quote
  #2  
Old 05-13-2019, 09:07 AM
bgagnon bgagnon is offline
VanDyke Technical Support
 
Join Date: Oct 2008
Posts: 3,974
Hi Azim,

I do not understand SecureCRT's role in your project.

Are you connecting a local shell session in SecureCRT?

If so, since the Local Shell inherits from the Default session, you will need to make changes to the Default session:
  1. Set Terminal emulation to Xterm (Terminal > Emulation category; this is the default for 8.1 and newer versions)
  2. Enable ANSI Color option (Terminal > Emulation category; this is on by default in 8.3 and newer verions)
  3. Character encoding should be set to UTF-8 (Terminal > Appearance category)
  4. Font should be set to Menlo (Terminal > Appearance category)
  5. Add the following lines to the end of your .bash_profile (e.g. from within native Terminal, run: vi ~/.bash_profile, then add the two lines to the bottom of the file and save it.)
    export LC_ALL=en_US.UTF-8
    export LANG=en_US.UTF-8

  6. Map the following keystrokes so that they send character codes that are expected for Mac bash shell (Terminal > Emulation > Mapped Keys category)
    Option/Alt+Left --> \033b
    Option/Alt+Right --> \033f
    Home --> \033[H
    End --> \033[F
__________________
Thanks,
--Brenda

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 09:22 PM.