Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > General

Reply
 
Thread Tools Display Modes
  #1  
Old 10-24-2017, 04:36 AM
tomuk5 tomuk5 is offline
Registered User
 
Join Date: Dec 2014
Posts: 5
Exclamation SecureCRT on Ubuntu 17.10

Hi,

iv tried running both the 8.1 GA and 8.3 BETA releases on Ubuntu 17.10 and both are lagging really badly so as to be un-usable.

both of these versions operated fine on 17.04

is there plans to support the 17.x Ubuntu releases soon?

Many Thanks
Reply With Quote
  #2  
Old 10-24-2017, 09:16 AM
ekoranyi ekoranyi is offline
VanDyke Technical Support
 
Join Date: Jan 2017
Posts: 654
Hi tomuk5,

I'm sorry you're having trouble.

Can you tell me a little more about the issue? When you say "lagging really badly so as to be un-usable" how does that present? What is lagging?

I have recorded your interest in our database of SecureCRT feature requests so that the product director can evaluate it for possible support in a future release.

Should a version of SecureCRT become available for Ubuntu 17.10 , we will be sure to let you know.

If you would like to be notified directly please send an email to Support@VanDyke.com with "Feature Request Forum Post 12873" in the subject line.
__________________
Thanks,
--Eric

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #3  
Old 10-24-2017, 12:03 PM
pbusque pbusque is offline
Registered User
 
Join Date: Oct 2017
Posts: 6
I performed a system upgrade this week-end, and I am too experiencing the same lags.


Copying / pasting would incur a 3 seconds freeze of Secure CRT.
Clicking on a tab would take up to 10 seconds to change.
Right clicking would take 3 seconds for the context menu to appears.

I don't see any IO wait or CPU increase during those freeze. I suspect some internal timeout, maybe from a service no longer available in Unbunto 17.X


Quote:
Version 8.1.4 (build 1443) - Official Release - August 10, 2017
Quote:
Distributor ID: Ubuntu
Description: Ubuntu 17.10
Release: 17.10
Codename: artful
Reply With Quote
  #4  
Old 10-24-2017, 12:13 PM
ekoranyi ekoranyi is offline
VanDyke Technical Support
 
Join Date: Jan 2017
Posts: 654
Hi pbusque,

Thanks for the feedback.

I've updated the feature request to include your feedback and contact information.
__________________
Thanks,
--Eric

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #5  
Old 10-25-2017, 05:52 AM
tomuk5 tomuk5 is offline
Registered User
 
Join Date: Dec 2014
Posts: 5
I think pbusque described it better than i did

input lag, slow to respond visually, switching tabs takes 10sec+
starting a connection via SSH can take 30sec+

it is as if a dependancy/library/service for SecureCRT has been removed from Ubuntu in 17.10 but SecureCRT is waiting on it/checking repeatedly with every action.

Quote:
Version 8.3.0 (build 1491)
AND / OR
Quote:
Version 8.1.4 (build 1443)
Quote:
Distributor ID: Ubuntu
Description: Ubuntu 17.10
Release: 17.10
Codename: artful

Last edited by tomuk5; 10-25-2017 at 05:55 AM.
Reply With Quote
  #6  
Old 10-25-2017, 09:25 AM
ekoranyi ekoranyi is offline
VanDyke Technical Support
 
Join Date: Jan 2017
Posts: 654
Hi tomuk5,

Thanks for getting back to us, I've provided your and pbusque's feedback to the development team. We'll be sure to let you know if a version of SecureCRT becomes available for 17.10.
__________________
Thanks,
--Eric

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #7  
Old 10-26-2017, 12:25 AM
mansson mansson is offline
Registered User
 
Join Date: May 2011
Posts: 7
Same problem as well

I have the same problem as well on Ubuntu 17.10 worked well on Ubuntu 17.04

Would be nice if you could fix this bug as soon as possible as the product is unusable on Ubuntu 17.10
Reply With Quote
  #8  
Old 10-26-2017, 04:03 AM
EditioN- EditioN- is offline
Registered User
 
Join Date: Oct 2017
Posts: 3
Exclamation

Hi,

Not supported platform but having the exact same issue using Arch, kernel 4.13.5-1.

Overall delayed behavior, it's quite unusable like this.
Reply With Quote
  #9  
Old 10-26-2017, 09:21 AM
ekoranyi ekoranyi is offline
VanDyke Technical Support
 
Join Date: Jan 2017
Posts: 654
Hi mansson,

I've added your contact information to the feature request for Ubuntu 17.10 support.

Should a future version of SecureCRT become available for 17.10 we'll be sure to let you know.

If you would like to be contacted directly please send an email to Support@VanDyke.com with "Feature Request Forum Post 12873" in the subject line.
__________________
Thanks,
--Eric

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #10  
Old 10-26-2017, 09:24 AM
ekoranyi ekoranyi is offline
VanDyke Technical Support
 
Join Date: Jan 2017
Posts: 654
Hi EditioN-,

As you noted Arch is not currently a supported OS.

I've included your contact information in a feature request for Arch support. We'll be sure to let you know if a version of SecureCRT becomes available for this distribution.

If you would like to be contacted directly please send an email to Support@VanDyke.com with "Arch Linux Feature Request Forum Post 12873" in the subject line.
__________________
Thanks,
--Eric

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #11  
Old 10-26-2017, 01:06 PM
pbusque pbusque is offline
Registered User
 
Join Date: Oct 2017
Posts: 6
I also tested with an older version of SecureCRT
Same latency issues on Ubuntu 17.10

Quote:
Version 8.0.4 (build 1252) - Official Release - December 6, 2016
Reply With Quote
  #12  
Old 10-26-2017, 01:59 PM
jdev's Avatar
jdev jdev is offline
VanDyke Technical Support
 
Join Date: Nov 2003
Location: Albuquerque, NM
Posts: 1,039
Quote:
Originally Posted by pbusque View Post
I also tested with an older version of SecureCRT
Same latency issues on Ubuntu 17.10
I've installed a fresh Ubuntu 17.10 machine, and although we haven't built, tested, or certified any version of SecureCRT for any Ubuntu 17.x platform, my installation of SecureCRT 8.1.4 is working flawlessly, and without any lagging issues of any kind.

If you'd like to troubleshoot further, here's what I'd suggest:
  1. Close all instances of SecureCRT.
  2. Open a native "terminal" window and 'su' to root (e.g. sudo su -).
  3. Run the following command on the command line as root. It will loop waiting for SecureCRT to start, then begin tracing SecureCRT system calls to a file:
    while true; do pid=$(pgrep 'SecureCRT' | head -1); if [[ -n "$pid" ]]; then strace -tt -p "$pid" > strace.txt 2>&1; break; fi; done
  4. After issuing the above command, launch SecureCRT how you normally would, and perform the steps in SecureCRT that exhibit the sluggishness you're seeing.
  5. Once you've seen the sluggishness occur in SecureCRT, wait about 30 seconds and then open the native "terminal" window in which you ran the 'while true...' command in, and press Ctrl+C
  6. Compress the strace.txt file to reduce the size (and time it would take to transfer): bzip2 strace.txt

The strace.txt file will almost assuredly contain sensitive information that should not be posted to a public forum such as this, so please DO NOT post your strace.txt file to this forum.

Please send email to support@vandyke.com with a subject of something like, "ATTN: Forum thread 12873 (SecureCRT Ubuntu 17.x strace)". If your compressed strace log is <= 10MB in size, go ahead and attach it. Otherwise, we'll provide you with a way to upload it securely to us using your VanDyke Software download account (so please send your message to us from the same email address you use to download SecureCRT, or at least let us know what that address is so we can set up the secure upload mechanism).

--Jake
__________________
Jake Devenport
VanDyke Software
Technical Support
YouTube Channel: https://www.youtube.com/vandykesoftware
Email: support@vandyke.com
Web: https://www.vandyke.com/support
Reply With Quote
  #13  
Old 10-26-2017, 02:30 PM
pbusque pbusque is offline
Registered User
 
Join Date: Oct 2017
Posts: 6
I've send the detailed log by email.

I can share this in the meanwhile.

I'm seeing a lot of "Resource temporarily unavailable" being printed during the action that freeze SecureCRT

Quote:
15:27:33.481948 write(20, "W", 1) = 1
15:27:33.481970 sendmsg(21, {msg_name=NULL, msg_namelen=0, msg_iov=[{iov_base="l\1\0\1\0\0\0\0\7\0\0\0i\0\0\0\1\1o\0\1\0\0\0/\0\0\0\0\0\0\0"..., iov_len=128}, {iov_base="", iov_len=0}], msg_iovlen=2, msg_controllen=0, msg_flags=0}, MSG_NOSIGNAL) = 128
15:27:33.482013 poll([{fd=21, events=POLLIN}], 1, 25000) = 1 ([{fd=21, revents=POLLIN}])
15:27:33.482158 recvmsg(21, {msg_name=NULL, msg_namelen=0, msg_iov=[{iov_base="l\2\1\1\4\0\0\0Iu\2\0-\0\0\0\6\1s\0\7\0\0\0:1.1751\0"..., iov_len=2048}], msg_iovlen=1, msg_controllen=0, msg_flags=MSG_CMSG_CLOEXEC}, MSG_CMSG_CLOEXEC) = 68
15:27:33.482198 write(20, "W", 1) = 1
15:27:33.482218 recvmsg(21, {msg_namelen=0}, MSG_CMSG_CLOEXEC) = -1 EAGAIN (Resource temporarily unavailable)
15:27:33.482292 write(20, "W", 1) = 1
So SecureCRT is trying to connect, repeatly, on something that is disable.
Reply With Quote
  #14  
Old 10-26-2017, 05:25 PM
EditioN- EditioN- is offline
Registered User
 
Join Date: Oct 2017
Posts: 3
Sent as well, even though from Arch.
My log is similar and at the end it seems a lot of printer commands (old linux printer issue as well?)

I basically opened SecureCRT, quickconnect SSH2, couple of commands, then opened another quickconnect SSH2 session, couple of commands and then switched tabs (this last is the longest delay, around 4seconds)

Thanks for your help guys.
Reply With Quote
  #15  
Old 10-27-2017, 12:01 PM
pbusque pbusque is offline
Registered User
 
Join Date: Oct 2017
Posts: 6
Those who have issues, which 'flavor' of Ubuntu are you using?

I'm using Kubunu+Cinnamon and I'm experiencing the problem.
Someone mentioned they were using Arch. Which desktop manager does it come with?


I noticed that if I install ubuntu-desktop and disable cups, the problem goes away. But installing ubuntu-desktop could have potential side effect on the other desktops,
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 11:51 PM.