Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > General

Notices

Reply
 
Thread Tools Display Modes
  #1  
Old 01-20-2006, 04:46 PM
zorglups's Avatar
zorglups zorglups is offline
Registered User
 
Join Date: Sep 2004
Location: Belgium
Posts: 61
Clipboard type used during the paste should be TEXT

SecureCRT 5.1.0 build 207

This is not easy to explain so let's go step by step...

I'm working all day long on Unix machines using SecureCRT.
On the other hand, I'm working as well with MS Office.

Unfortunately when one will write a doc or a procedure (or even a single mail in Outlook), MS Word will do "autocorrect" stuffs on the text as you type.

For example if you type "ls -lrt", MS Word will translate it to "Ls -lrt" where the dash (ascii 0x2D) has been replaced by a stupid longer dash (ascii 0x96).

See the attached example.txt. Open it in an editor and then switch to hexa view.

If you copy this text (including the 0x96 character) and paste it on securecrt, the character is sent as-is while I would like to have the 0x20 char sent.

You might tell me that the problem is on the MS Word side and that I should disable the "autocorrect" option.
Well. Most of the documents used are not mine and it will be difficult to change the settings in a 5000 engineer group.

I had a look at the windows clipboard API and found that several versions of the clip are saved. (http://www.codeproject.com/clipboard...clipboard1.asp)


What would do the trick is to have an option to use the CF_TEXT version of the clipboard during the paste instead of CF_UNICODETEXT.

Code:
HANDLE hClipboardData = GetClipboardData(CF_TEXT);
Another solution is to parse the clipboard upon past and replace ugly characters. (for example, you copy the text, paste it into notepad, copy it again, then paste it in SecureCRT). This is not my prefered solution.

Please please please please please please please please please please

Thank,

Pierre.

Links of interrest:

http://www.codeproject.com/clipboard....asp?msg=26830
Attached Files
File Type: txt example.txt (54 Bytes, 689 views)
Reply With Quote
  #2  
Old 01-21-2006, 07:36 AM
jpv jpv is offline
Weekend Programmer and CEO
 
Join Date: Nov 2003
Location: VanDyke Software
Posts: 54
Quote:
Originally Posted by zorglups
SecureCRT 5.1.0 build 207

This is not easy to explain so let's go step by step...

I'm working all day long on Unix machines using SecureCRT.
On the other hand, I'm working as well with MS Office.

Unfortunately when one will write a doc or a procedure (or even a single mail in Outlook), MS Word will do "autocorrect" stuffs on the text as you type.

For example if you type "ls -lrt", MS Word will translate it to "Ls -lrt" where the dash (ascii 0x2D) has been replaced by a stupid longer dash (ascii 0x96).

See the attached example.txt. Open it in an editor and then switch to hexa view.

If you copy this text (including the 0x96 character) and paste it on securecrt, the character is sent as-is while I would like to have the 0x20 char sent.

You might tell me that the problem is on the MS Word side and that I should disable the "autocorrect" option.
Well. Most of the documents used are not mine and it will be difficult to change the settings in a 5000 engineer group.

I had a look at the windows clipboard API and found that several versions of the clip are saved. (http://www.codeproject.com/clipboard...clipboard1.asp)


What would do the trick is to have an option to use the CF_TEXT version of the clipboard during the paste instead of CF_UNICODETEXT.

Code:
HANDLE hClipboardData = GetClipboardData(CF_TEXT);
Another solution is to parse the clipboard upon past and replace ugly characters. (for example, you copy the text, paste it into notepad, copy it again, then paste it in SecureCRT). This is not my prefered solution.

Please please please please please please please please please please

Thank,

Pierre.

Links of interrest:

http://www.codeproject.com/clipboard....asp?msg=26830
I believe we used to use CF_TEXT. As we've improved our UNICODE support, I expect we switched to CF_UNICODE.

If we made this an option, would it be acceptable for this to be a global option?

--Jeff
Reply With Quote
  #3  
Old 01-23-2006, 02:12 AM
zorglups's Avatar
zorglups zorglups is offline
Registered User
 
Join Date: Sep 2004
Location: Belgium
Posts: 61
For me a global option is even better.

This has always been like this and I'm a user of secureCRT for about 2 years now - I'm not sure that this behaviour is caused by your implementation of unicode.

I can make several trials if you wan't me to.

Best regards,

Pierre.
Reply With Quote
  #4  
Old 01-24-2006, 12:38 PM
miked's Avatar
miked miked is offline
Registered User
 
Join Date: Feb 2004
Posts: 2,039
We've entered a request for the option to specify the clipboard text format. If we implement it and you would like to be notified by e-mail, please send e-mail to support@vandyke.com and reference thread 1223.
__________________
Mike
VanDyke Software
Technical Support
[http://www.vandyke.com/support]

Last edited by miked; 01-24-2006 at 12:40 PM.
Reply With Quote
  #5  
Old 01-25-2006, 04:29 AM
zorglups's Avatar
zorglups zorglups is offline
Registered User
 
Join Date: Sep 2004
Location: Belgium
Posts: 61
Thumbs up

Thanks,

I made some further testing (with the clipboard.exe found in the system32 directory) and if the TEXT version of the clipboard was sent, this would be fine for me.

I can be your beta tester any time.

Pierre.
Reply With Quote
  #6  
Old 01-25-2006, 04:03 PM
miked's Avatar
miked miked is offline
Registered User
 
Join Date: Feb 2004
Posts: 2,039
We've updated the feature request with the information you provided above.

Thanks for your willingness to beta test!
__________________
Mike
VanDyke Software
Technical Support
[http://www.vandyke.com/support]
Reply With Quote
  #7  
Old 02-02-2006, 01:10 AM
mstbone67a mstbone67a is offline
Registered User
 
Join Date: Feb 2006
Posts: 11
I have noticed the same problem.. I have 2 dif machines
one with secure crt5.0
one with secure crt3.2

the 5.0 has problems pasting the -


ps -aef | grep backup comes out with a junk character in the place of the -

Is there anything to change in 5.0 to allow this or its just a "feature" currently
Reply With Quote
  #8  
Old 02-03-2006, 06:15 PM
jdev's Avatar
jdev jdev is offline
VanDyke Technical Support
 
Join Date: Nov 2003
Location: Albuquerque, NM
Posts: 1,099
We plan to release a fix for this as part of 5.1 beta 2.

If you would like to try out a pre-release version before then, please send a request via e-mail to support@vandyke.com with a subject of "VanDyke Forum - Thread #1223".

--Jake
__________________
Jake Devenport
VanDyke Software
Technical Support
YouTube Channel: https://www.youtube.com/vandykesoftware
Email: support@vandyke.com
Web: https://www.vandyke.com/support
Reply With Quote
  #9  
Old 02-15-2006, 05:54 AM
zorglups's Avatar
zorglups zorglups is offline
Registered User
 
Join Date: Sep 2004
Location: Belgium
Posts: 61
I tried the Beta 2 and this works perfectly.

Many thanks for this. This will save me and my colleagues from frutrations in the future.

Pierre
Reply With Quote
  #10  
Old 05-31-2006, 05:33 AM
zorglups's Avatar
zorglups zorglups is offline
Registered User
 
Join Date: Sep 2004
Location: Belgium
Posts: 61
Exclamation Regression on SCRT 5.1.2 (build 274)

Hi,

I'm sure I saw this working on my PC !!!

Today, it doesn't work anymore.

My global.ini contains:
S:"Clipboard Data Format"=CF_TEXT

My SCRT version is now 5.1.2 (build 274)

Can you help me?

Thanks,

Pierre.
Reply With Quote
  #11  
Old 05-31-2006, 04:17 PM
jjh jjh is offline
VanDyke Customer Support
 
Join Date: Feb 2004
Posts: 815
Hello Pierre.

If I understand you correctly, when you were using SecureCRT
5.1 Beta 2, you were able to paste text the way you needed
it to be pasted if you specified the following setting in
your global.ini file:

S:"Clipboard Data Format"=CF_TEXT

When you upgraded to SecureCRT 5.1.2 (official version), the
behavior reverted back to the exact same behavior you were
experiencing before.

Is that correct or is the behavior different from the way it
was before?

Thanks

JJH
Reply With Quote
  #12  
Old 06-01-2006, 01:54 AM
zorglups's Avatar
zorglups zorglups is offline
Registered User
 
Join Date: Sep 2004
Location: Belgium
Posts: 61
Quote:
Originally Posted by jjh
Hello Pierre.

If I understand you correctly, when you were using SecureCRT
5.1 Beta 2, you were able to paste text the way you needed
it to be pasted if you specified the following setting in
your global.ini file:

S:"Clipboard Data Format"=CF_TEXT
That is correct.

Quote:
Originally Posted by jjh
When you upgraded to SecureCRT 5.1.2 (official version), the
behavior reverted back to the exact same behavior you were
experiencing before.
Actually, I'm alpha/beta tester. My jump was not exactely from 5.1 Beta 2 to 5.1.2 Official release. Instead I have been using several intermediate betas provided by Maureen.

I saw the regression before but did not have the time to report it. Sorry for that.

Quote:
Originally Posted by jjh
Is that correct or is the behavior different from the way it
was before?
Actually, the behaviour is like before 5.1 B2. I mean that if I copy an hyphen (kind of long dash) from a pdf or from office, it will not paste as a - in securecrt as explained earlier in the thread.

I can run an 'instrumented' version to help you in the debugging if needed.

Thanks for your reply,

Pierre.
Reply With Quote
  #13  
Old 06-02-2006, 02:15 PM
miked's Avatar
miked miked is offline
Registered User
 
Join Date: Feb 2004
Posts: 2,039
Hi Pierre,

Thanks for this information. I've created a bug report and let the product manager know.
__________________
Mike
VanDyke Software
Technical Support
[http://www.vandyke.com/support]
Reply With Quote
  #14  
Old 06-05-2006, 03:31 PM
miked's Avatar
miked miked is offline
Registered User
 
Join Date: Feb 2004
Posts: 2,039
Pierre,

Could you send a message to support@vandyke.com and include your global.ini file and an example PDF or office file containing the hyphen (kind of long dash) you referred to, please?

In the message please refer to forum thread 1223.

Thank you.
__________________
Mike
VanDyke Software
Technical Support
[http://www.vandyke.com/support]
Reply With Quote
  #15  
Old 06-12-2006, 08:45 AM
zorglups's Avatar
zorglups zorglups is offline
Registered User
 
Join Date: Sep 2004
Location: Belgium
Posts: 61
I just did it now.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 06:44 AM.