Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > SecureCRT on the Mac

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 02-01-2019, 04:55 PM
ashleywlee ashleywlee is offline
Registered User
 
Join Date: Feb 2019
Posts: 2
SecureCRT 8.5.2 - Session settings are not being updated properly

I am trying to connect to a Red Hat Enterprise Linux Server release 6.10, using an existing session. However, due to my client's password rules, I recently had to update my password for multiple servers. Upon trying to sign in with the new password, SecureCRT fails to connect and promptly disconnects after the correct password is provided.

I have confirmed I am able to login to this server using ssh via a local session launched in SecureCRT and by launching SecureCRT as a different user on my Mac and creating a new session for this server using the same user credentials. I have attempted deleting this session and the entry in the known hosts file, then recreating the session form scratch. However it appears some erroneous setting was not removed and is still continuing to cause login attempts to fail.

Other than the session files is there anything else which needs to be removed to delete all of the saved settings for this one session?
Reply With Quote
  #2  
Old 02-01-2019, 05:24 PM
jdev's Avatar
jdev jdev is offline
VanDyke Technical Support
 
Join Date: Nov 2003
Location: Albuquerque, NM
Posts: 931
What specific mechanism did you use to change the passwords in all of your saved sessions?

Are you able to successfully connect to this same host if you use an ad hoc connection instead of your saved session (say, use the Connect bar -- type in the hostname and press Enter -- so that your problematic saved session isn't used)

Is SecureCRT configured to use your mac's keychain to save passwords?
Global Options > General, Mac options, "Use KeyChain"
If so, then you'll need to update your saved password in Keychain or disable that option and use SecureCRT's built-in password storage method.

If the Use KeyChain option is not enabled, and you're still having trouble getting connected, you'll want to enable Trace Options to see the underlying negotiation that's happening between SecureCRT and the server to determine what clues exist there. See this video on our YouTube channel for instructions on how to generate a trace options debug log.

You'll also want to check your Session Options > Connection > Logon Actions category to see if the Automate Logon option is enabled and responsible for handling the password prompt for you (sending the incorrect password there).

Posting Trace Options to these public forums is not advisable since the data can be sensitive/revealing.
If you need further assistance, please send your trace options debug log by email to support@vandyke.com with a subject of "ATTN: Jake - Forum thread #13385"

--Jake
__________________
Jake Devenport
VanDyke Software
Technical Support
YouTube Channel: https://www.youtube.com/vandykesoftware
Email: support@vandyke.com
Web: https://www.vandyke.com/support
Reply With Quote
  #3  
Old 02-04-2019, 08:54 AM
ashleywlee ashleywlee is offline
Registered User
 
Join Date: Feb 2019
Posts: 2
Thanks, the keychain was the problem. After removing the bad keychain for my account I was able to login upon the next connection attempt.
Reply With Quote
  #4  
Old 02-04-2019, 01:31 PM
jdev's Avatar
jdev jdev is offline
VanDyke Technical Support
 
Join Date: Nov 2003
Location: Albuquerque, NM
Posts: 931
Quote:
Originally Posted by ashleywlee View Post
Thanks, the keychain was the problem. After removing the bad keychain for my account I was able to login upon the next connection attempt.
Thanks for updating the community as to the solution to the problem you were facing.

--Jake
__________________
Jake Devenport
VanDyke Software
Technical Support
YouTube Channel: https://www.youtube.com/vandykesoftware
Email: support@vandyke.com
Web: https://www.vandyke.com/support
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 08:52 AM.