Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > SecureCRT on the Mac

Reply
 
Thread Tools Rating: Thread Rating: 6 votes, 5.00 average. Display Modes
  #1  
Old 12-18-2010, 11:06 AM
jocke jocke is offline
Registered User
 
Join Date: Dec 2010
Posts: 3
First impressions, and a few questions

Hi,

I've been a Mac-user for a while, and have always used Terminal.app. I've now decided to give SecureCRT a go, mostly because of the sessions-handling and logging.

So far, so good. I've got most things figured out, I guess. Theres a lot of small things (mainly cosmetic) that seems "weird", but I guess that's just because I'm so used to Terminal.app.

However, I have a few questions;

- Is it possible to only have the "terminal"-field semi-transparent? (That is, keep the menu- and tabs-area non-transparent, but the rest semi-transparent? Just like you can with Terminal.app)

- How can you change the font? This might sound really stupid, but changing "Session Options -> Terminal -> Appearance -> Fonts" has no effect (even when opening the session again). I guess there's something _really_ basic I'm missing here...

- Using a local shell, perl complains that it couldn't set the locale. This issue is not present in Terminal.app. I'm no expert at this area, so I don't know what could cause it?

Code:
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LC_ALL = (unset),
        LANG = "en_US@currency=NOK"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
(output from Terminal.app below)

Code:
joachim@keklolwtf: ~ $ locale
LANG="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_CTYPE="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_ALL=
SecureCRT has the same locales available, so I don't know why it behaves like this? Is it some setting somewhere? Can I make SecureCRT set it manually some way?

(output below from SecureCRT)

Code:
joachim@keklolwtf: ~ $ locale -a | grep en_US.UTF-8
en_US.UTF-8
- It doesn't seem to handle some of the Norwegian letters well (Æ, Ø and Å), even if SecureCRT is set to UTF-8. But I guess this is somewhat related to the issue above.

Code:
joachim@keklolwtf: ~/Desktop/Test $ ls
joachim@keklolwtf: ~/Desktop/Test $ touch æøå.txt ææøøåå.txt
joachim@keklolwtf: ~/Desktop/Test $ ls -al
total 0
drwxr-xr-x   4 joachim  staff  136 Dec 18 19:03 .
drwx------+ 17 joachim  staff  578 Dec 18 19:03 ..
-rw-r--r--   1 joachim  staff    0 Dec 18 19:03 ????????a??a??.txt
-rw-r--r--   1 joachim  staff    0 Dec 18 19:03 ????a??.txt
joachim@keklolwtf: ~/Desktop/Test $ ls -al | grep "æ"
-rw-r--r--   1 joachim  staff    0 Dec 18 19:03 ææøøåå.txt
-rw-r--r--   1 joachim  staff    0 Dec 18 19:03 æøå.txt
That's it. For now. (-:

Last edited by jocke; 12-20-2010 at 10:19 AM.
Reply With Quote
  #2  
Old 12-20-2010, 10:15 AM
jocke jocke is offline
Registered User
 
Join Date: Dec 2010
Posts: 3
One more thing;

- When setting "%U@%H" in "Session Options -> Terminal -> Appearance -> Window -> Title bar", it only displays "@<host>" when using a local shell (it doesn't manage to fetch the username for some reason).

Last edited by jocke; 12-20-2010 at 10:27 AM.
Reply With Quote
  #3  
Old 12-20-2010, 02:10 PM
rtb rtb is offline
VanDyke Technical Support
 
Join Date: Aug 2008
Posts: 4,306
Hi jocke,

Thanks for the feedback and questions.
Quote:
- Is it possible to only have the "terminal"-field semi-transparent? (That is, keep the menu- and tabs-area non-transparent, but the rest semi-transparent? Just like you can with Terminal.app)
This is not currently possible. I have created a feature request in our SecureCRT development database to add this capability. Should a future release of SecureCRT have the ability to set only the terminal window to transparent, we will post to this forum thread.

With regards to %U not working in the title bar, I have created another feature request to add this capability for local shells.

If you would like to be notified directly, please complete and submit the form at the following location for each request:
Submit Feature Request
Quote:
- How can you change the font? This might sound really stupid, but changing "Session Options -> Terminal -> Appearance -> Fonts" has no effect (even when opening the session again). I guess there's something _really_ basic I'm missing here...
What font are you choosing? Is it a fixed width font?

What file (.bashrc, .bash_profile, etc.) contains the Perl calls to configure your bash environment?

Would you be able to send a file with Norwegian characters and a screenshot of how the characters should appear to support@vandyke.com with a subject of Attn: Todd - Forum thread 6625?
__________________
--Todd

VanDyke Software
Technical Support
support@vandyke.com
505-332-5730
Reply With Quote
  #4  
Old 12-21-2010, 05:46 PM
jocke jocke is offline
Registered User
 
Join Date: Dec 2010
Posts: 3
Quote:
Originally Posted by rtb
What font are you choosing? Is it a fixed width font?
Monaco.

Quote:
What file (.bashrc, .bash_profile, etc.) contains the Perl calls to configure your bash environment?
I have no idea. I've never seen that "error" in Terminal.app, and none of the .bashrc/.bash/.profile contains any calls to Perl, as far as I can see.

Quote:
Would you be able to send a file with Norwegian characters and a screenshot of how the characters should appear to support@vandyke.com with a subject of Attn: Todd - Forum thread 6625?
Done.
Reply With Quote
  #5  
Old 12-22-2010, 09:32 AM
rtb rtb is offline
VanDyke Technical Support
 
Join Date: Aug 2008
Posts: 4,306
Hi jocke,

Thanks for the information. With regards to the font, are you indicating that you are not able to change the font to Monaco, or that you are not able to use a font other than Monaco?

If you are trying to switch from Monaco, what new font are you trying to use?

If you are switching to Monaco, what font are you currently using?

With regards to the Perl warnings and the Norwegian character problem, please see my email response.
__________________
--Todd

VanDyke Software
Technical Support
support@vandyke.com
505-332-5730
Reply With Quote
  #6  
Old 12-22-2010, 09:49 AM
Maureen's Avatar
Maureen Maureen is offline
VanDyke Product Director
 
Join Date: Feb 2004
Location: Albuquerque, NM
Posts: 1,531
Quote:
Originally Posted by jocke
One more thing;

- When setting "%U@%H" in "Session Options -> Terminal -> Appearance -> Window -> Title bar", it only displays "@<host>" when using a local shell (it doesn't manage to fetch the username for some reason).
This functionality has been added to a pre-beta version of SecureCRT. If you would be interested in trying it, please send e-mail to me at Maureen.Jett@vandyke.com.

Maureen
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 06:04 AM.