Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > General

Reply
 
Thread Tools Display Modes
  #1  
Old 02-11-2020, 09:12 PM
SuHK SuHK is offline
Registered User
 
Join Date: Jul 2004
Posts: 10
How to connect with WebDAV?

I just purchased an upgrade to 8.7 and wanted to add a WebDAV connection to an OwnCloud instance in SecureFX, but I can't find a lot of info on it.

I chose HTTPS as protocol. But usually you would enter an URL for a WebDAV connection, not just a hostname. For instance:

your-ip-address/owncloud/remote.php/webdav

Entering the URL in the hostname field won't work.

Am I missing something?

Last edited by SuHK; 02-11-2020 at 09:26 PM. Reason: better title
Reply With Quote
  #2  
Old 02-12-2020, 11:45 AM
bgagnon bgagnon is offline
VanDyke Technical Support
 
Join Date: Oct 2008
Posts: 4,219
Hi SuHK,

I am not entirely sure myself.

I think you would use your-ip-address as hostname for the https session and then just paste the rest (/owncloud/remote.php/WebDAV) in the address bar of the remote window.

But I am seeking to verify that with the SecureFX product manager. I've also requested the SecureFX Help files get updated with the info.
__________________
Thanks,
--Brenda

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #3  
Old 02-13-2020, 02:33 PM
bgagnon bgagnon is offline
VanDyke Technical Support
 
Join Date: Oct 2008
Posts: 4,219
Hi SuHK,
Quote:
Entering the URL in the hostname field won't work.
In what way didn't it work? Could you not even save a session with that info in the hostname field?

If you could, just the connection was unsuccessful, I suggest you:
  • Enable logging to a file. You can configure logging to a file in the File Transfer / Options / Advanced category of SecureFX's Global Options.
  • Set the protocol to HTTPS and configure the hostname as the URL you would normally connect to (your-ip-address/owncloud/remote.php/WebDAV)
When it fails, send the log file as an attachment to support@vandyke.com and reference Attn Brenda - Forum Thread #14070 in the subject line.

If you can't even save the session with the full path (your-ip-address/owncloud/remote.php/WebDAV), try just your-ip-address as hostname and provide that log file instead.
__________________
Thanks,
--Brenda

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #4  
Old 02-14-2020, 01:37 AM
SuHK SuHK is offline
Registered User
 
Join Date: Jul 2004
Posts: 10
Quote:
Originally Posted by bgagnon View Post
In what way didn't it work? Could you not even save a session with that info in the hostname field?
If you enter "cloud.server.com/remote.php/webdav" in the new connection wizard it throws an illegal character error and won't continue. That's when I made the initial post.

I later found out if you enter https://cloud.server.com/remote.php/webdav it truncates to cloud.server.com and saves "remote.php/webdav" as initial directory without notice. But connecting still won't work with different error messages.

We followed up via email with logs.
Reply With Quote
Reply

Tags
https , webdav


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 10:25 PM.