Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > General

Reply
 
Thread Tools Display Modes
  #1  
Old 10-02-2008, 05:59 AM
vbritt vbritt is offline
Registered User
 
Join Date: Oct 2008
Posts: 5
Secure CRT quits responding

I am having a problem with SecureCRT version 6.1, build 349 where the window quits responding to user inputs but continues to display outputs. This condition only seems to happen when I am viewing a continuous stream of information coming from the channel (such as using the tail -f command to view log files).

My SecureCRT session is configured as a telnet window using a VT100 emulation. My scrollback buffer is set to 32000 (I like to be able to scroll back over a lot of information). I am configured, under terminal options, to send a protocol NO-OP every 60 seconds and I also send a "\n" string every 900 seconds (I have these options configured to prevent the channel on the distant end from closing do to no user input).

What happens is the log information is scrolling on the screen just fine. Once I am ready to exit from the Unix tail function I hit the delete key. This exists from the tail function and returns me back to a user input configuration. If I have viewed a log for an extended period of time, with a significant amount of text having scrolled across the screen, the delete key does not work. The window stays locked in the tail session showing the scrolling text from the log file. The window still functions outputting information from the channel it just won't accept any keyboard actions. My only choice is to close the session and open another one in a different tab or a new session entirely. This did not happen on version 6.0 and earlier.

Has anyone else experienced this situation and figured out a solution to this problem?

System configuration: AMD64 X2-4800 Processor, 2 Gigs ram memory, running Microsoft Windows XP Home with the latest patches from Microsoft installed.
Reply With Quote
  #2  
Old 10-02-2008, 10:26 AM
kbarnette kbarnette is offline
VanDyke Technical Support
 
Join Date: Aug 2007
Posts: 587
Hi vbritt,

Thanks for the detailed description of the issue you are seeing. I have not been able to reproduce the behavior you reported.

I will need a little more information to understand more about what may be occurring.

When SecureCRT stops receiving keyboard actions, are the SecureCRT menus still accessible?
To clarify, can you still pull down the 'File' menu, or is the entire application hung?

Also, it may be helpful to view a raw log of your session.

Could you enable 'Raw Log Session' from the SecureCRT 'File' menu, reproduce the behavior, and send us the raw log?
Since some of the data being scrolled on the screen may be proprietary information not appropriate for a public forum, feel free to send the raw log as an attachment in an e-mail to support@vandyke.com, with the subject of the e-mail message set to 'Attn: Kevin Forum Thread 3222'.
Reply With Quote
  #3  
Old 10-02-2008, 02:54 PM
vbritt vbritt is offline
Registered User
 
Join Date: Oct 2008
Posts: 5
> When SecureCRT stops receiving keyboard actions, are the SecureCRT menus > still accessible?

> To clarify, can you still pull down the 'File' menu, or is the entire application > hung?

I have not tried to use the various menu choices. However, I have selected the folder ICON and spawned a new session in another TAB so I would have to say that the application isn't hung. The keyboard works fine in the session in the new tab. If I switch back to the tab that is hung it stays hung and nothing that I have tried will re-establish communications with the window. It simply continues to scroll the log until the task either finishes or I close the tab. I don't know if this matters or not but I usually have several tabs open at a time with each tab doing different things when this happens.

I will try to get it to fail again and send you a log file. It may take a day or so to get it to fail. As I said previously, I have to be viewing a large stream of data to get this situation to occur.
]
Reply With Quote
  #4  
Old 10-07-2008, 06:32 AM
vbritt vbritt is offline
Registered User
 
Join Date: Oct 2008
Posts: 5
Quote:
Originally Posted by vbritt
> When SecureCRT stops receiving keyboard actions, are the SecureCRT menus > still accessible?

I will try to get it to fail again and send you a log file. It may take a day or so to get it to fail. As I said previously, I have to be viewing a large stream of data to get this situation to occur.
]
I loaded version 6.1.1 shortly after posting this problem. To date I have been unable to duplicate this problem on my system. Before I loaded version 6.1.1 it was happening every few days. I don't know if it is related to a correction that was made in version 6.1.1 or not, but it seems to have gone away.
Reply With Quote
  #5  
Old 10-07-2008, 08:51 AM
kbarnette kbarnette is offline
VanDyke Technical Support
 
Join Date: Aug 2007
Posts: 587
Hi vbritt,

Thanks for the note about upgrading to 6.1.1.

Please let us know if the issue resurfaces.

Last edited by jdev; 10-07-2008 at 09:37 AM.
Reply With Quote
  #6  
Old 10-09-2008, 04:47 PM
vbritt vbritt is offline
Registered User
 
Join Date: Oct 2008
Posts: 5
It happened again

Kevin,

I am sending you the log file with the contents of the session. The menu selections at the top of the screen function and also the icons, but the session will not accept any key strokes in the active window. I have to click the red X in the upper right hand corner to exit the window. That is the only way to get out of the window.

Virgil
Reply With Quote
  #7  
Old 10-24-2008, 05:16 AM
V.Vorobyev V.Vorobyev is offline
Registered User
 
Join Date: Feb 2006
Location: Novosibirsk, Russia
Posts: 23
Unhappy

we have trouble that (i think) looks like yours

we have >30 servers with VShell installed (from 2.3 tilll last 3.5.1)
secureCRT 5.x.x (may be some 4.x)
all servers run under w2k3 sp1/sp2 (few stations w/xp_sp2)
all clients run xp_sp2/3

99% of users use Far manager on the server side (trough secureCRT)
and 99% of them got black screen or hanged connections daily
many of this hanged connections are going to be a zombie on nightly vshell service restart and make some troubles (like locked files).

the connection may hangs on the first few second or later (minutes and hours some times).

few days ago i tried again to understand what happens
in most cases i saw string "00016: Received EOF on stdout from running program" and than console hangs. cloned session work perfectly.


p.s. Far manager = grate file manager for admins - lot of plugins. 4ex: to manage services/users and acl/ etc.


p.p.s. sorry for my bad english.

Last edited by jdev; 10-27-2008 at 10:32 AM.
Reply With Quote
  #8  
Old 10-24-2008, 08:49 AM
kbarnette kbarnette is offline
VanDyke Technical Support
 
Join Date: Aug 2007
Posts: 587
Hi V.Vorobyev,

Thanks for the update.

Does the hang issue occur regardless of the version of VShell running on the remote end?

Also, could you enable 'Debug' in the 'Logging' category of the VShell Control Panel, reproduce the hang issue, and send me (via our open e-mail thread) the resulting VShell log file?
Reply With Quote
  #9  
Old 10-27-2008, 04:23 AM
V.Vorobyev V.Vorobyev is offline
Registered User
 
Join Date: Feb 2006
Location: Novosibirsk, Russia
Posts: 23
Quote:
Originally Posted by kbarnette
Does the hang issue occur regardless of the version of VShell running on the remote end?
i think no.
75-90% of hangs happens under Scraper module
looks like Far+Scraper problem

i catched Far+Scraper bug right now, but log (w/debug on) shows nothing about it (lines are not added since i connected and started Far Manager till far|connection hangs - keypress has no effect inside the connection window)

i'll try to catch hang with blank screen (rest 25-10% of hangs).
Reply With Quote
  #10  
Old 10-27-2008, 10:00 AM
kbarnette kbarnette is offline
VanDyke Technical Support
 
Join Date: Aug 2007
Posts: 587
Hi V.Vorobyev,

A new build of SecureCRT has been made available that has resolved some other issues with the application hanging.

Could you please send an e-mail to support@vandyke.com so that I can make this new build available to you for download?
It would be helpful if the subject of your e-mail was 'Attn: Kevin Forum Thread 3222'
Also, at the times when a connection is hung, does VShell still accept new connections?
Reply With Quote
  #11  
Old 10-27-2008, 11:20 PM
V.Vorobyev V.Vorobyev is offline
Registered User
 
Join Date: Feb 2006
Location: Novosibirsk, Russia
Posts: 23
Quote:
Originally Posted by kbarnette
Also, at the times when a connection is hung, does VShell still accept new connections?
yes, i can clone connection and continue to work
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 05:05 AM.