Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > General

Reply
 
Thread Tools Display Modes
  #1  
Old 02-12-2018, 09:36 AM
dlbannerman dlbannerman is offline
Registered User
 
Join Date: Aug 2012
Posts: 1
Using vi in ssh2 session

It's probably me, but...

I'm at the command line for a session and type in 'man lpq'. Instead of the man page scrolling the session text gets replaced with the man page. When I exit then I'm taken back to the command line, but the line above is the line where I typed in 'man lpq'. Is there a way to control this behavior so that I can scroll back into the man page for information I need to enter the command I just looked up?

Using SecureCRT 8.1.4

Dan
Reply With Quote
  #2  
Old 02-12-2018, 10:04 AM
ekoranyi ekoranyi is offline
VanDyke Technical Support
 
Join Date: Jan 2017
Posts: 654
Hi dlbannerman,

You may be able to get the behavior you're looking for by disabling the Alternate Screen Switching mode. This can be done by navigating to Options > Session Options > Terminal > Emulation > Modes and removing the check next to Enable alternate screen switching.



Does making this change give you the behavior you're looking for?
Attached Images
File Type: png AlternateScreenSwitching.png (33.6 KB, 667 views)
__________________
Thanks,
--Eric

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #3  
Old 02-21-2018, 10:00 AM
markweiser markweiser is offline
Registered User
 
Join Date: Nov 2017
Posts: 3
Very nice, it works properly to me now!

Thank you, Eric
Reply With Quote
Reply

Tags
scrolling , vi editor


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 04:42 PM.