Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > SecureCRT on the Mac

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 01-11-2018, 07:59 PM
blittlej blittlej is offline
Registered User
 
Join Date: Jan 2018
Posts: 4
OSX 10.13.2 can not get telnet handler change

I have OSX 10.13.2. I have to click on URL's to telnet into applications. I can not get OSX to change is telnet handler (e.i., telnet://x.x.x.x) to change to secureCRT (happens in Chrome and Safari). I have spent hours on it. I have changed the Global.ini file to check telnet handler. I have tried to disable SIP on the mac and put telnet into /usr/bin.

I think if I can force the global.ini file in secureCRT to check the telnet client again it would work. But, no luck.
Reply With Quote
  #2  
Old 01-12-2018, 07:58 AM
bgagnon bgagnon is offline
VanDyke Technical Support
 
Join Date: Oct 2008
Posts: 3,557
Hi blittlej,

If you need to clear the default handler, you might try these steps (but I don't think they have been verified on High Sierra):
  • Open ~/Library/Preferences/com.apple.LaunchServices/com.apple.launchservices.secure.plist

  • Locate the entry that sets the telnet handler to SecureCRT and delete it; then save.

  • In Terminal, from your home folder, run the following command:
    /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/Support/lsregister -kill -r -domain local -domain system -domain user

  • Now, rerun SecureCRT to register SecureCRT (actually the Url Launcher) as the telnet handler. If the prompt doesn't show up, you may need to set the Check Shell Telnet Command to 00000001.

By "changed the Global.ini file", you mean you made that change referenced above, correct?
D:"Check Shell Telnet Command"=00000000
to
D:"Check Shell Telnet Command"=00000001

I have added this thread to a feature request in our product enhancement database to make it easier to set SecureCRT as the default Telnet handler (url). Should a future release of SecureCRT include this feature, notification will be posted here.

If you prefer direct email notification, send an email to support@vandyke.com and include "Feature Request - Forum Thread #12977" in the subject line or use this form from the support page of our website.
__________________
Thanks,
--Brenda

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #3  
Old 01-13-2018, 05:45 PM
blittlej blittlej is offline
Registered User
 
Join Date: Jan 2018
Posts: 4
THAT WORKED!!! You are a god send. I spent hours on this.
Reply With Quote
  #4  
Old 02-23-2018, 08:10 AM
blittlej blittlej is offline
Registered User
 
Join Date: Jan 2018
Posts: 4
It stopped working.

For some reason it stopped working.

I re did all the steps again and it will still not work. Do you have any other suggestions?
Reply With Quote
  #5  
Old 02-23-2018, 08:26 AM
bgagnon bgagnon is offline
VanDyke Technical Support
 
Join Date: Oct 2008
Posts: 3,557
Hi blittlej,

Were there any changes on the machine between when it was working and when it stopped?
__________________
Thanks,
--Brenda

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #6  
Old 02-23-2018, 08:32 AM
blittlej blittlej is offline
Registered User
 
Join Date: Jan 2018
Posts: 4
I do not know if there were any.

I finally got it to work by downloading and installing iterm2 and selecting that as the default telnet handler. Then I rebooted. Then I opened secureCRT and it asked to be the default handler again (yaa!). I glad it is working again. But, hopefully this will give you a clue what changed.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 05:36 PM.