Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > General

Reply
 
Thread Tools Display Modes
  #1  
Old 05-04-2017, 07:33 AM
Chris2NyCE Chris2NyCE is offline
Registered User
 
Join Date: Apr 2017
Posts: 8
Question Unable to view full run configs in one session

Pretty sure this is another easy one, but ive changed a ton of settings and cant find one that does what i need.

When SSHing into a switch and doing a "sh run" - i can scroll through the output from top to bottom, but if i try to scroll back up to look through the config, its cut off.

Its as if the session/window will only hold so much view-able data. I dint have this issue on an older version, and just noticed it cuts off my 'scroll back' data.

Is there a setting i can change so that if my run config is (for example) 2000 lines, i can scroll up to view it without having to create an output file?
Reply With Quote
  #2  
Old 05-04-2017, 08:08 AM
Casey Casey is offline
Registered User
 
Join Date: Oct 2011
Posts: 114
Look under the session (or default session to affect everything) options.

Under Terminal / Emulation, you'll see 'scrollback buffer'. I have mine set to 50,000. Granted, that's probably a bit overkill.
Reply With Quote
  #3  
Old 05-04-2017, 09:54 AM
Chris2NyCE Chris2NyCE is offline
Registered User
 
Join Date: Apr 2017
Posts: 8
Tried that too, except i set mine to '99999' and still no go.

For 'S and giggles' i just set it to 50k and i still only go back roughly half of my running configs. And its only a 4 blade chassis. :-/
Reply With Quote
  #4  
Old 05-04-2017, 09:57 AM
Chris2NyCE Chris2NyCE is offline
Registered User
 
Join Date: Apr 2017
Posts: 8
Ah i see the issue.

The newest update i got removed my tabbed sessions and opened up a new instance each time.

Its set to 99999 on some and 1000 on others.

Fixed both settings and now im good.

Thanks for the input.
Reply With Quote
  #5  
Old 05-04-2017, 10:32 AM
bgagnon bgagnon is offline
VanDyke Technical Support
 
Join Date: Oct 2008
Posts: 4,436
Hi Chris2NyCE,

If you want to set a common scrollback buffer value in all sessions, you would want to use Default Session. There is also a mechanism for changing a subset of all sessions. Note that the scrollback buffer limit is presently 128,000 lines.

I have added this thread to a feature request in our product enhancement database to have an infinite scrollback buffer (unlimited). Should a future release of SecureCRT include this feature, notification will be posted here.

If you prefer direct email notification, send an email to support@vandyke.com and include "Feature Request - Forum Thread #12683" in the subject line or use this form from the support page of our website.


Quote:
The newest update i got removed my tabbed sessions and opened up a new instance each time.
If you did not change it yet, enabling Connect sessions in tabs in the Terminal category of Global Options should get you back to tabbed sessions.


Thanks also, Casey, for your input!
__________________
Thanks,
--Brenda

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #6  
Old 05-04-2017, 11:11 AM
Chris2NyCE Chris2NyCE is offline
Registered User
 
Join Date: Apr 2017
Posts: 8
Im back to where i should be now :-D

Thanks!
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 05:59 AM.