Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > File Transfer

Notices

Reply
 
Thread Tools Display Modes
  #1  
Old 06-08-2012, 07:03 AM
renep renep is offline
Registered User
 
Join Date: Mar 2006
Location: Amsterdam, the Netherlands
Posts: 56
UTF-8 characters fine in SecureCRT, not in SecureFX

In SecureCRT 6.7.4 on Windows 7, when I connect to a Linux server, non-ASCII UTF-8 characters in directory and file names display fine. For example, Belgium in Dutch is correctly displayed as België.

When I open the same directory in SecureFX (again 6.7.4 on Windows 7), in the remote window I see België instead. This suggests that the two bytes of the UTF-8 representation of ë are incorrectly interpreted as individual characters.

Also, when I create a directory with a non-ASCII UTF-8 character in its name in SecureFX, the Linux ls command in SecureCRT shows wrong characters.

Session Options > Terminal > Appearance > Character encoding is set to UTF-8. Does this perhaps apply only to SecureCRT? If so, how do I tell SecureFX to interpret the remote encoding as UTF-8?
__________________
René
Reply With Quote
  #2  
Old 06-08-2012, 08:16 AM
bgagnon bgagnon is offline
VanDyke Technical Support
 
Join Date: Oct 2008
Posts: 4,636
Hello René,

There is an .ini only option in SecureFX to allow UTF-8 characters in filenames.

Session .ini files are stored in the configuration folder. The location of your installation's Configuration folder is found in the General category of SecureFX's Global Options. If you make this change to the Default.ini file, the option will be enabled for any future saved sessions.
  • Close SecureFX

  • Change the following:
D:"Filenames Always Use UTF8"=00000000
to
D:"Filenames Always Use UTF8"=00000001
__________________
Thanks,
--Brenda

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #3  
Old 06-08-2012, 09:07 AM
renep renep is offline
Registered User
 
Join Date: Mar 2006
Location: Amsterdam, the Netherlands
Posts: 56
Yes, that seems to do the trick. Thank you.
__________________
René
Reply With Quote
  #4  
Old 06-08-2012, 09:12 AM
bgagnon bgagnon is offline
VanDyke Technical Support
 
Join Date: Oct 2008
Posts: 4,636
Hi René,

Great, I am glad to hear the issue is resolved. Thanks for posting an update!
__________________
Thanks,
--Brenda

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #5  
Old 04-08-2014, 04:34 PM
Maureen's Avatar
Maureen Maureen is offline
VanDyke Product Director
 
Join Date: Feb 2004
Location: Albuquerque, NM
Posts: 1,612
Quote:
Originally Posted by bgagnon View Post
Hello René,

There is an .ini only option in SecureFX to allow UTF-8 characters in filenames.

Session .ini files are stored in the configuration folder. The location of your installation's Configuration folder is found in the General category of SecureFX's Global Options. If you make this change to the Default.ini file, the option will be enabled for any future saved sessions.
  • Close SecureFX

  • Change the following:
D:"Filenames Always Use UTF8"=00000000
to
D:"Filenames Always Use UTF8"=00000001
This option is now available in the GUI in a pre-beta version of SecureFX. If you'd like to try it, please email me at Maureen.Jett@vandyke.com.

Maureen
Reply With Quote
Reply

Tags
character encoding , utf-8

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 06:45 PM.