View Single Post
  #1  
Old 04-26-2010, 09:33 PM
SteveB-in-LV's Avatar
SteveB-in-LV SteveB-in-LV is offline
Registered User
 
Join Date: Sep 2009
Posts: 7
Cut-and-paste Buffer seems to be truncated or garbled after about 3300 characters

Greetings all.

...here's hoping this is an easy question to answer for someone out there.

During a CLI session with a Cisco device (Serial, telnet or SSH – it doesn’t seem to matter), when I try to send a series of CLI commands using cut-and-paste, the full contents of the Cut-and-Paste Buffer seem to get garbled, out-of-sync with the IOS CLI or otherwise don't make it all the way to the target device.

Somewhere after about the first 3300 characters, the target CLI starts complaining about unrecognized commands and bad syntax. The last command in the buffer DOES make it to the CLI but a comparison of the sent commands and the resulting configuration on the target device, show that several commands in the middle of the sent buffer did not make it.

I suspect this is some kind of a buffer limitation or a timing issue between the sending device and the Cisco CLI.

Has anyone seen this problem before and know of a fix for it?
For instance, is there some kind of delay or flow-control setting that might need to be adjusted or is there a way to increase the size of the cut-and-paste buffer recognized by SecureCRT?

Thanks for reading this post and giving it some of your attention.

--Steve

Last edited by SteveB-in-LV; 07-01-2010 at 05:34 PM.
Reply With Quote