View Single Post
  #7  
Old 05-08-2014, 01:21 PM
rtb rtb is offline
VanDyke Technical Support
 
Join Date: Aug 2008
Posts: 4,306
Hi evoxfan,

In the putty log, you don't see where it selects ssh-rsa, but you can see the following indicating that ssh-rsa was selected:
Event Log: ssh-rsa 2048 50:ea:90:20:35:e2:c5:19:5a:bf:31:3e:10:db:1d:59

We have seen issues with some SSH servers which advertise that they support ssh-dss, but don't really support it. This could be a configuration issue or a bug in the server.

SecureCRT prefers ssh-dss, and if a server advertises that it supports it, SecureCRT will select it.

It is possible to configure SecureCRT to prefer ssh-rsa, but in your version a registry change is required.
WARNING:
If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
Here is the information to edit the registry so SecureCRT will prefer ssh-rsa:
Path: HKEY_CURRENT_USER\Software\Policies\VanDyke
Key (REG_SZ) Name: "Host Key Algorithms"

Value: comma-separated, ordered list (no spaces) of algorithms our clients will support.
For example:
ssh-rsa, ssh-dss, x509v3-sign-rsa, x509v3-sign-dss
Does this help to resolve the issue?
__________________
--Todd

VanDyke Software
Technical Support
support@vandyke.com
505-332-5730
Reply With Quote