View Single Post
  #1  
Old 02-21-2008, 01:31 PM
mattdey mattdey is offline
Registered User
 
Join Date: Feb 2008
Posts: 6
Jump scroll issue with scrollable regions.

I am useing SecureCRT 6.0 and I think there is a bug with jumpscroll. When i use SecureCRT with the GNU screen utility with a hardstaus line and run something that will scoll a large number of lines SecureCRT seems to be doing smooth scrolling. When I am outside of GNU screen, or inside of GNU screen without a hard status line and run the same command Jump scolling works fine.

I tested this against Putty and I did not experience the same problem which leads me to belive it's a problem with Secure CRT and not gnu Screen.

I did a little digging around and the problem appears to begin once GNU screen send the escape sequence to set the Scrollable Region. Which would explain why it happens inside of the GNU scrren utility only when I have a status line at the bottom.

I have tried setting Secure CRT to use different emulations and nothing seemed to make a differece.

Here is my .screenrc file
==============================================
term xterm
startup_message off

# turn visual bell on
vbell on
vbell_msg " Wuff ---- Wuff!! "

# define a bigger scrollback, default is 100 lines
defscrollback 5120

# terminfo and termcap for nice 256 color terminal
# bold colors - necessary for some reason
attrcolor i "+b"

# tell screen how to set colors. AB = background, AF=foreground
termcapinfo xterm 'Co#256:AB=\E[48;5;%dm:AF=\E[38;5;%dm:ti=\E[?47h:te=\E[?47l'

# erase background with current bg color
defbce "on"
hardstatus alwayslastline
hardstatus string '%{= kG}[ %{+bG}%H %{G}][%= %{=kw}%?%-Lw%?%{r}(%{W}%n*%f%t%?(%u)%?%{r})%{G}%?%+Lw%?%?%= %{G}][%{C}.%y%m%d %{W}%c %{g}]'
==============================================
Reply With Quote