VanDyke Software Forums

VanDyke Software Forums (
-   File Transfer (
-   -   Perform and SSH with SecureFX (

Reno 05-13-2019 03:13 PM

Perform and SSH with SecureFX
I work with VM's grouped into zones where there are multiple related VM's for each zone and where I only have CRT connections built for the main VM of each zones. Normally with SecureCRT, I would SSH into the different related VM's for the zones if needed. I have SecureCRT button bar buttons built to SSH into the different related VM's.

Building each individual connection for all zones would be too time consuming where I'd end up with hundreds of connections.

What would be nice is if I could start a SecureFX connection and then be able to SSH into one of the related VM's when needed (ssh zoneclient01 ...).


berdmann 05-13-2019 04:00 PM

Hi Reno,

If you have the bundle installed you can connect to a remote host with SecureFX and then launch an SSH session in SecureCRT by pressing the SecureCRT icon on the SecureFX toolbar.

However, there is not a way to accomplish this in SecureFX alone. I have submitted a feature request on your behalf to implement such functionality. Should a future release of SecureCRT include this functionality, notification will be posted here.

If you prefer direct email notification, send an email to and include *"Feature Request - Forum Thread #13541"* in the subject line.

georg 06-09-2019 03:30 PM

You mentioned
"SSH session in SecureCRT by pressing the SecureCRT icon on the SecureFX toolbar. "

I have downloaded the bundled on mac and do not see this SecureCRT icon in the FX toolbar.

Been battling to try this desired feature to be able to su login as root (since server does not allow root logins) which I managed to achieve from CRT side, but when on FX side choosing session created from CRT I do not get logged in as root as it appears its due to this missing icon.

When I downloaded the bundle, dmg opened disk image and I manually copied both files over to Applications folder. Its not normal to have to do this on mac as there is usually an installer and then to drag files to Applications folder.

Any light appreciated.

berdmann 06-10-2019 11:37 AM

1 Attachment(s)
Hi georg,

You said that you manually copied the files to your Applications folder. Did you move SecureCRT and SecureFX to your Applications folder at the same time?

In order to avoid integration issues, SecureCRT and SecureFX should have been moved to the Applications folder separately, one at a time.

You said that the SecureCRT icon is missing in SecureFX, correct?

georg 06-12-2019 05:34 PM

Thank you for your follow up.

Your recommendation did make a change when moving one file at a time to Applications folder.
Now I see the SecureCRT icon from the SecureFX app (mac)

Why not handle the Installer process to properly have the apps copied as needed or mention it clearly when one needs to drag these files one by one?

Next issue if you can help: Not seeing any docs or videos how to use his bundled version.
Do I create the connection to my host via ssh with a username from FX and login and then click on CRT icon to get console from CRT to be able to do a sudo to enter as root and when I come back to FX, I will be logged in as root?


berdmann 06-12-2019 06:17 PM

Hi georg,

I am glad to hear that the installation instructions provided helped to resolve the integration issues that you were facing!

I have submitted a bug report on your behalf to document the issue! Should progress be made toward a resolution, or further information be required, I will contact you here.

The integration feature allows you to connect to a host originally in either SecureCRT or SecureFX, and then launch a connection to that same host in either SecureCRT or SecureFX without having to reverify.

You should be able to use SecureFX's "Substitute User" tool to switch to root in SecureFX. Please refer to our tip:

Does the "Substitute User" tool provide you with the functionality that you desire in SecureFX?

georg 06-12-2019 06:53 PM


This "Substitute User" tool seems to require a Windows Vshell since not good for me since I am on mac OS.

Been battling to figure out why I am getting prompts now for password when that is not prioritized since I need to logon via ssh keys. When I disable password I get 'all gssapi mechanisms failed' error notices.
Have a feeling the CRT or FX is not reading my location of my keys that are standard on macs.

Managed to do it via its terminal (local shell) but the no transfer method selected appears since local shell mode does not allow file transfer to be selected. But this approach finds my private ssh keys, so lost a bit now.

georg 06-12-2019 07:02 PM

terminal: SSH2

Then get prompted for this below:

Please enter login information for xx.xx.xx.xx
Username: xxxxxx
The private key file could not be found:

Note that the public key file and private key file must have the same name (e.g., "" and "Identity") and must be located in the same folder.

No such file or directory


Have a feeling something is wrong with these bundled versions. Will try solo ones tomorrow as I recall this worked fine before fixing the bundled one-by-one copy issue.

georg 06-12-2019 07:31 PM

1 Attachment(s)
Trying another MAC, seems new errors and same on another mac.
Attached screenshot.

Tried older releases and they were installable, but they wont accept the trial run. :(

berdmann 06-13-2019 10:13 AM

Hi georg,

You are absolutely correct about the substitute user feature that I mentioned previously. My apologies for the recommendation.

I spoke with my colleagues about your goal to switch to root after successfully authenticating your SFTP connection. The SFTP protocol, itself, does not currently provide a way to change users after authenticating with the server.

Thus, there is not currently a way to "su" after authenticating with the SFTP server. This functionality is only available with VShell because we added an extension to the VShell server to provide this capability, specifically.

As for your authentication issue, can you please tell me what steps you took to create and configure your public-key in SecureCRT?

All times are GMT -6. The time now is 09:39 AM.