VanDyke Software Forums

VanDyke Software Forums (https://forums.vandyke.com/index.php)
-   SecureCRT 5.0 Alpha/SecureFX 3.0 Alpha (https://forums.vandyke.com/forumdisplay.php?f=12)
-   -   Session Wizard default port incorrect for SSH2 (https://forums.vandyke.com/showthread.php?t=440)

mwb 02-16-2005 06:36 AM

Session Wizard default port incorrect for SSH2 (build 711)
 
When creating a new session with the new Session Wizard for SSH2, the port defaults to 23, not 22. Selecting SSH1 correctly sets it to 22.

Also, if you select "None" for the protocol, then select SFTP, the port again is incorrectly set to 23.

-Matt

Maureen 02-16-2005 06:31 PM

For a while, there was a bug where SSH2 was defaulting to port 23 and it's possible that your default session got saved this way. SSH2 and SFTP share configuration information, which is why you're seeing the same behavior for SFTP.

There are a couple of ways to fix this. If you haven't made changes to your default session, you could go into your config folder and delete the Default.ini file. If you have made changes to your default session that you'd like to save, you could edit your defaut session through the Global Configuration dialog and change the default port for SSH2 to 23. If neither of these fixes the problem, please let me know.

Maureen

mwb 02-17-2005 08:16 PM

Thanks... That appears to have corrected that problem. However, while correcting that issue, I found another.

If you go into Default Session/Edit Default Settings… , Click on File Transfer, then FTP/SFTP, in the grayed out “File Creation Mask” is three characters. Selecting any other button results in a popup saying “Invalid Octal Digit.” The only way to get out is to cancel.

This exists in build 722.


-Matt

Maureen 02-18-2005 01:23 PM

Thanks for posting this report. I saw the same thing you described. Once I exited SecureCRT and restarted, I didn't see it again. Are you able to get it to happen consistently?

Maureen

mwb 02-19-2005 04:01 PM

Yes... I can reproduce it every time. It only appears after selecting "File Transfer"

Matt


All times are GMT -6. The time now is 08:54 AM.