VanDyke Software Forums

VanDyke Software Forums (https://forums.vandyke.com/index.php)
-   Secure Shell (https://forums.vandyke.com/forumdisplay.php?f=15)
-   -   Cut-and-paste Buffer seems to be truncated or garbled after about 3300 characters (https://forums.vandyke.com/showthread.php?t=5502)

SteveB-in-LV 04-26-2010 09:33 PM

Cut-and-paste Buffer seems to be truncated or garbled after about 3300 characters
 
Greetings all. :)

...here's hoping this is an easy question to answer for someone out there.

During a CLI session with a Cisco device (Serial, telnet or SSH – it doesn’t seem to matter), when I try to send a series of CLI commands using cut-and-paste, the full contents of the Cut-and-Paste Buffer seem to get garbled, out-of-sync with the IOS CLI or otherwise don't make it all the way to the target device.

Somewhere after about the first 3300 characters, the target CLI starts complaining about unrecognized commands and bad syntax. The last command in the buffer DOES make it to the CLI but a comparison of the sent commands and the resulting configuration on the target device, show that several commands in the middle of the sent buffer did not make it.

I suspect this is some kind of a buffer limitation or a timing issue between the sending device and the Cisco CLI.

Has anyone seen this problem before and know of a fix for it?
For instance, is there some kind of delay or flow-control setting that might need to be adjusted or is there a way to increase the size of the cut-and-paste buffer recognized by SecureCRT?

Thanks for reading this post and giving it some of your attention.

--Steve

rtb 04-27-2010 10:08 AM

Hi Steve,

I am sorry to hear that you are having difficulty transferring data to your Cisco device.

SecureCRT does not have a 3300 character limit to the copy and paste buffer, so this does not seem like it is the problem. I would expect that the data is being sent to the Cisco device faster than it can handle the data.

You may want to try one of the Send delay options found in the Terminal / Emulation / Advanced category of the Session Options dialog.

Does this information help you resolve the issue you are seeing?


All times are GMT -6. The time now is 04:27 PM.