VanDyke Software Forums

VanDyke Software Forums (https://forums.vandyke.com/index.php)
-   Scripting (https://forums.vandyke.com/forumdisplay.php?f=14)
-   -   Automation gets interrupted (https://forums.vandyke.com/showthread.php?t=10435)

riziriz 04-29-2012 03:58 AM

Automation gets interrupted
 
I have a SecureCRT script that takes backups of devices like FWSMs, ASA, Cisco Routers and Switches , Juniper Devices, Alpine, Blackdiamond and summit switches.

In our network there is one computer which has open access to all network devices so all shift engineers log onto that and use secureCRT AND my backup script is also supposed to run on same computer.

The problem is if some one is using SecureCRT for trouble shooting or some other tasks then my script do not run at scheduled time but if no one else is using then it opens the SecureCRT and does the job..

So is there any possibility that the script runs in background/silently like some system service instead of trying to opening the complete software (SecureCRT).

or
Script may used its own instance of software (SecureCRT) with out disturbing other ongoing tasks.
or

At least some one guide me.. what can i do that my script may run smoothly at the same time when other shift engineers are working on that computer using SecureCRT..


-rizwan saeed

bgagnon 04-30-2012 12:03 PM

Hi Rizwan,

Have you included logging in your script?

If so, could you send examples of that (success and failure) to support@vandyke.com?

Please include "Attn Brenda - Forum Thread #10435" in the subject line.

Also, please attach a copy of the script you are using to backup the devices.


All times are GMT -6. The time now is 05:22 AM.